Bug 112183 - RHEL boot -> dual (RHEL, Fedora) boot not well supported
RHEL boot -> dual (RHEL, Fedora) boot not well supported
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-15 15:23 EST by Michael Tiemann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 20:13:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Tiemann 2003-12-15 15:23:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030819

Description of problem:
I have a laptop that was cleanly installed with a taroon beta, laid
out thusly:

hda1 = /boot (the boot partition for RHEL WS)
hda2 = /home (user data)
hda3 = /fedora (partition anticipating a fedora install)
hda5 = / (the root filesystem for RHEL WS)
hda6 = /swap

I just installed Fedora Core 1, selecting manual partitioning and hda3
as the default partition.  It came to pass that the installer told me,
in effect, "I'm about to create a boot record for you, do you want me
to write that to disk and make it your default or add other boot rules?"

I used "Add" to create a new boot rule, and somehow found the old rule
from WS (I don't remember if anaconda simply did a grub find across
all partitions and give me options, or if I told it to look in
/dev/hda1).  In any event, I renamed that as "RHEL WS", made it the
default, and then let the installer proceed to create a grub.conf file
with both a Fedora boot and RHEL boot option.

The installation finished and it was time to reboot.

When I tried to reboot using RHEL WS, it failed, unable to find the
proper file listed as /boot/vmlinuz-mumble-WS (presumably looking at
(hd0,2)/boot/vmlinuz-mumble-WS when it should have been looking at
(hd0,0)/vmlinuz-mumble-WS or some such).  I ultimately got this
debugged with Chris Kloiber's help, but it looks like going from a
default single-boot system to a dual boot (where the second boot
environment is entirely within one partition) ain't quite right.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Partition with hda1=/boot, hda3=/fedora, hda5=/, hda6=/swap
2. Install RHEL-WS cleanly on a laptop to hda1 and hda5
3. Install Fedora-Core to hda3
4. When given a choice about boot records, keep the fedora default,
but use the menu to "add" the existing RHEL-WS boot info, and see if
there's not a problem with a dangling/misdirected reference.

Actual Results:  Can boot Fedora, cannot boot RHEL WS without
editing/fixing grub.conf

Expected Results:  Should be able to boot either system w/o any
additional intervention.

Additional info:
Comment 1 Jeremy Katz 2003-12-16 20:13:02 EST
If you want to support multiple Linux installations like this, you
need to install the boot loader to the partition in the advanced boot
loader options screen and then you can chainload the different GRUBs
(and add the various boot partitions from anaconda).  You can also use
the same /boot partition and choose not to install a boot loader at
all and then grubby ends up doing the right thing as the kernel
package gets installed.

Doing anything else has far too many variables that really can't be
just magically determined.

Note You need to log in before you can comment on or make changes to this bug.