Bug 1121855 - fail to convert to vmdk with the streamOptimized subformat
Summary: fail to convert to vmdk with the streamOptimized subformat
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Ademar Reis
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 05:08 UTC by Sibiao Luo
Modified: 2014-07-22 19:44 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-22 19:44:05 UTC


Attachments (Terms of Use)

Description Sibiao Luo 2014-07-22 05:08:34 UTC
Description of problem:
I'm trying to convert a qcow2 image file to the vmdk, but it fail to convert with i/o error and can't write to allocated cluster for streamOptimized.
BTW, 
1.Also tried other subformat "monolithicSparse(default), monolithicFlat, twoGbMaxExtentSparse and twoGbMaxExtentFlat" which did not hit this issue.
2.Also tried rhel7 which did not hit this issue, it can finish converting successfully.
3.Also tried rhel6.5GA qemu-kvm version which also hit it, so this issue is not a regression.

Version-Release number of selected component (if applicable):
host info:
# uname -r && rpm -q qemu-kvm-rhev
2.6.32-492.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.430.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.prepare a qcow2 image file.
# qemu-img info RHEL-6.6-20140718.0-Server-x86_64.qcow2
image: RHEL-6.6-20140718.0-Server-x86_64.qcow2
file format: qcow2
virtual size: 10G (10737418240 bytes)
disk size: 3.0G
cluster_size: 65536
2.try to convert a qcow2 image file to the vmdk with streamOptimized subformat specified.
# qemu-img convert -p -f qcow2 RHEL-6.6-20140718.0-Server-x86_64.qcow2 -O vmdk test.qed -o subformat=streamOptimized

Actual results:
after step 2, it fail to convert with i/o error and can't write to allocated cluster for streamOptimized.
# qemu-img convert -p -f qcow2 RHEL-6.6-20140718.0-Server-x86_64.qcow2 -O vmdk test.qed -o subformat=streamOptimized
VMDK: can't write to allocated cluster for streamOptimized
error while writing sector 2600: Input/output error

Expected results:
I should convert a qcow2 to vmdk with streamOptimized subformat specified successfully. 

Additional info:
Backtrace as following:
(gdb) b exit
Breakpoint 1 at 0x125a8
(gdb) r convert -p -f qcow2 RHEL-6.6-20140718.0-Server-x86_64.qcow2 -O vmdk test.qed -o subformat=streamOptimized
Starting program: /usr/bin/qemu-img convert -p -f qcow2 RHEL-6.6-20140718.0-Server-x86_64.qcow2 -O vmdk test.qed -o subformat=streamOptimized
[Thread debugging using libthread_db enabled]
[New Thread 0x7ffff59a1700 (LWP 37211)]
VMDK: can't write to allocated cluster for streamOptimized
error while writing sector 2600: Input/output error


Breakpoint 1, 0x00007ffff625ad30 in exit () from /lib64/libc.so.6
Missing separate debuginfos, use: debuginfo-install glib2-2.28.8-1.el6.x86_64 glibc-2.12-1.147.el6.x86_64 glusterfs-api-3.6.0.24-1.el6.x86_64 glusterfs-libs-3.6.0.24-1.el6.x86_64 libaio-0.3.107-10.el6.x86_64 libuuid-2.17.2-12.17.el6.x86_64 openssl-1.0.1e-28.el6.x86_64 usbredir-0.5.1-1.el6.x86_64 zlib-1.2.3-29.el6.x86_64
(gdb) bt
#0  0x00007ffff625ad30 in exit () from /lib64/libc.so.6
#1  0x00007ffff6243d24 in __libc_start_main () from /lib64/libc.so.6
#2  0x00007ffff7f98fe9 in _start ()
(gdb)

Comment 1 Sibiao Luo 2014-07-22 05:27:21 UTC
(In reply to Sibiao Luo from comment #0)
> Description of problem:
> I'm trying to convert a qcow2 image file to the vmdk, but it fail to convert
> with i/o error and can't write to allocated cluster for streamOptimized.
> BTW, 
> 1.Also tried other subformat "monolithicSparse(default), monolithicFlat,
> twoGbMaxExtentSparse and twoGbMaxExtentFlat" which did not hit this issue.
# for i in {monolithicSparse,monolithicFlat,twoGbMaxExtentSparse,twoGbMaxExtentFlat,streamOptimized}; do qemu-img convert -p -f qcow2 RHEL-6.6-20140718.0-Server-x86_64.qcow2 -O vmdk test.$i.vmdk -o subformat=$i; done 
    (100.00/100%)
    (100.00/100%)
    (100.00/100%)
    (100.00/100%)
VMDK: can't write to allocated cluster for streamOptimized
error while writing sector 2600: Input/output error

> 2.Also tried rhel7 which did not hit this issue, it can finish converting
> successfully.
> 3.Also tried rhel6.5GA qemu-kvm version which also hit it, so this issue is
> not a regression.

Comment 2 Ademar Reis 2014-07-22 19:44:05 UTC
This is a corner case in the write support for VMDK. It works in RHEL7/upstream, so closing as WONTFIX in RHEL6 due to limited capacity.


Note You need to log in before you can comment on or make changes to this bug.