Bug 1121883 - on app creation, I get a code 500 always even though the app is created.
Summary: on app creation, I get a code 500 always even though the app is created.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Pod
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: N. Harrison Ripps
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 06:32 UTC by Peter Ruan
Modified: 2015-05-15 02:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 18:39:08 UTC


Attachments (Terms of Use)

Description Peter Ruan 2014-07-22 06:32:12 UTC
Description of problem:
on app creation, I get a code 500 always even though the app is created.

Version-Release number of selected component (if applicable):
version 4

How reproducible:

always.

Steps to Reproduce:
1. use rhc or web to try and create a type of any kind.
2.
3.

Actual results:
times out and returns 'execution expired'

Expected results:


Additional info:

Comment 1 N. Harrison Ripps 2014-07-22 11:58:09 UTC
Is this a problem that you are seeing with the Origin v4 VM, or did you install origin v4 another way?

Comment 2 Peter Ruan 2014-07-22 16:58:08 UTC
this is from the pre-packaged image running on VirtualBox.  The ip is 10.14.16.216.  You can log into it using the libra.pem as root.

Comment 3 N. Harrison Ripps 2014-07-22 20:55:09 UTC
I've dug into this further. This is the result of a problem with VirtualBox networking. It only seems to manifest when the host machine is on the same subnet that VirtualBox is using for NAT. Unfortunately, Red Hat uses this subnet, which explains why I did not encounter the issue when I finished the VM while working remotely.

Here is an explanation of the workaround for people who encounter this problem. Please test it out. If it works for you I will update the VM guide with a section on this.


To work around this:
1. If the OpenShift Origin v4 VM is running, shut it down.

2. In the main VirtualBox app, go to File => Preferences (or VirtualBox => Preferences on OS X). The Preferences window will appear.

3. In the Preferences window, click on the Network tab, and once on the Network tab, choose the Host-only Networks subtab.

4. If no host-only networks are listed, create one by pressing the "+" icon. A new host-only network will appear with a name like "vboxnet0".

5. Now press OK to close the Preferences window. Then, in the VirtualBox Manager main window, select the OpenShift Origin v4 VM and press the Settings button. The VM settings will appear.

6. Click on the Network tab. The Adapter 1 tab should be selected. From the Attached to: pulldown, select Host-only Adapter. Below that pulldown, the Name pulldown should automatically populate with the name of the Host-only adapter that you created.

7. Now change to the Adapter 2 tab, and if the Enable Network Adapter checkbox is checked for Adapter 2, uncheck it. Finally, press OK to close the machine Settings window.

Now you should be able to launch the VM and work with it as described in the VM guide.

NOTE: An unfortunate limitation of this workaround is that you will not be able to launch community quickstarts. These depend on access to remote servers (primarily GitHub) that are not accessible to a VirtualBox VM that is using a Host-only adapter.

Comment 4 Peter Ruan 2014-07-22 21:18:26 UTC
Thanks for the detailed workaround.  FYI, my VM was using VirtualBox in the BridgeMode.

So if I were to use KVM, then this problem goes away?

Comment 5 N. Harrison Ripps 2014-07-23 11:31:29 UTC
Hopefully, yes. I have confirmed that the VM behaves normally as documented under the following conditions:

1. VirtualBox running somewhere other than our corporate network
2. VMWare anywhere

So please let me know how KVM works out. Also note that I am updating the VM shortly due to a mis configuration in the mDNS plugin.

Comment 6 openshift-github-bot 2014-07-23 18:31:22 UTC
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/c13088ad8c84ceb2fa5479179eb5e06799ff5c67
Bug 1121883: Added documentation to work around a known VirtualBox issue

Comment 7 N. Harrison Ripps 2014-07-23 18:39:08 UTC
Closed per above; the docs should show up at openshift.github.io this evening.


Note You need to log in before you can comment on or make changes to this bug.