Bug 1121889 - qemu-img refuse to create 0-sized vmdk images
Summary: qemu-img refuse to create 0-sized vmdk images
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Virtualization Maintenance
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1121891
TreeView+ depends on / blocked
 
Reported: 2014-07-22 06:46 UTC by Sibiao Luo
Modified: 2014-07-23 03:11 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1121891 (view as bug list)
Environment:
Last Closed: 2014-07-22 07:49:50 UTC


Attachments (Terms of Use)

Description Sibiao Luo 2014-07-22 06:46:39 UTC
Description of problem:
qemu-img refused to create 0-sized vmdk image, but qcow2 format will not be refused. I don't know whether VMware tools can allow us to create 0-sized image and operate on them.

Version-Release number of selected component (if applicable):
# uname -r && rpm -q qemu-kvm-rhev
2.6.32-492.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.430.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.use qemu-img to create 0-sized vmdk image.
# qemu-img create -f vmdk test.vmdk 0k
2.
3.

Actual results:
# qemu-img create -f vmdk test.vmdk 0k
Formatting 'test.vmdk', fmt=vmdk size=0 compat6=off zeroed_grain=off 
test.vmdk: error while creating vmdk: No such file or directory

Expected results:
It should work well if use qemu-img to create 0-sized vmdk image.

Additional info:
# qemu-img create -f qcow2 test.qcow2 0k
Formatting 'test.qcow2', fmt=qcow2 size=0 encryption=off cluster_size=65536 
# qemu-img info test.qcow2 
image: test.qcow2
file format: qcow2
virtual size: 0 (0 bytes)
disk size: 132K
cluster_size: 65536

Comment 1 Sibiao Luo 2014-07-22 06:55:19 UTC
(In reply to Sibiao Luo from comment #0)
> I don't know whether VMware tools can allow us to create 0-sized
> image and operate on them.
> 
I use the VMware vSphere Client(Version 5.1.0) to create new virtual disk with 0-sized specified, it will give a warning prompt message "The disk capacity entered was not a properly formed number or was out of range. It has been replaced with the nearest acceptable value." and replace into 1MB for recommending.

Best Regards,
sluo

Comment 2 Fam Zheng 2014-07-22 07:49:50 UTC
(In reply to Sibiao Luo from comment #1)
> (In reply to Sibiao Luo from comment #0)
> > I don't know whether VMware tools can allow us to create 0-sized
> > image and operate on them.
> > 
> I use the VMware vSphere Client(Version 5.1.0) to create new virtual disk
> with 0-sized specified, it will give a warning prompt message "The disk
> capacity entered was not a properly formed number or was out of range. It
> has been replaced with the nearest acceptable value." and replace into 1MB
> for recommending.
> 

Yes, we conform to the behavior of VMware tools. Intended.

Fam


Note You need to log in before you can comment on or make changes to this bug.