Bug 1122057 - unneeded openbox BuildRequires
Summary: unneeded openbox BuildRequires
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: rawhide
Hardware: All
OS: All
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 12:58 UTC by Benedikt Morbach
Modified: 2014-08-31 23:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 18:57:43 UTC


Attachments (Terms of Use)

Description Benedikt Morbach 2014-07-22 12:58:53 UTC
I'm working with the Base WG on reducing the since of the base package set a bit, as we currently need 1800 packages to be self-hosting (see also [1]).

I noticed that policycoreutils has a BuildRequires for openbox, but builds just fine without it, though it is needed at runtime.
Maybe that BuildRequires could be dropped?

Maybe we'll even eventually get to a base system that doesn't pull in half of X :)


[1] http://www.harald-hoyer.de/2014/01/14/self-hosting-fedora-base/

Comment 1 Daniel Walsh 2014-08-04 18:57:43 UTC
Fixed in policycoreutils-2.3-9.f22

Do I need to change this anwhere other then Rawhide?

Comment 2 Benedikt Morbach 2014-08-06 08:22:04 UTC
Thanks!

F21 would certainly be nice as well, I guess.

Comment 3 Daniel Walsh 2014-08-06 15:48:24 UTC
Fixed in policycoreutils-2.3-6.1.fc21


Note You need to log in before you can comment on or make changes to this bug.