Bug 112211 - TungstenE visor oops on sync, kernel-2.4.22-1.2132.nptl
TungstenE visor oops on sync, kernel-2.4.22-1.2132.nptl
Status: CLOSED DUPLICATE of bug 107929
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-16 05:32 EST by Andrey Bondarenko
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrey Bondarenko 2003-12-16 05:32:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
I can not sync Tungsten E on my kernel-2.4.22-1.2132.nptl for i686 kernel on p4, Asus P266B motherboard.
If I try to sync Tungsetn with some app via pilot-link, this application freeses. Strange thing, that on Athlon 2000+, Abit KG7 (amd 762 chipset) all works fine.

 visor.o can not be removed from kernel.

[root@bondarenko root]# lsmod
Module                  Size  Used by    Not tainted
visor                  13352   0
usbserial              22044   0  [visor]
ipx                    21284   0  (autoclean)
floppy                 57308   0  (autoclean)
ide-cd                 34432   0  (autoclean)
cdrom                  34560   0  (autoclean) [ide-cd]
cmpci                  39828   0  (autoclean)
gameport                3380   0  (autoclean) [cmpci]
soundcore               6468   4  (autoclean) [cmpci]
parport_pc             18756   1  (autoclean)
lp                      8580   0  (autoclean)
parport                37056   1  (autoclean) [parport_pc lp]
autofs                 12084   0  (autoclean) (unused)
e100                   55940   1
microcode               4188   0  (autoclean)
loop                   11512   0  (autoclean)
keybdev                 2656   0  (unused)
mousedev                5268   1
hid                    23908   0  (unused)
input                   5888   0  [keybdev mousedev hid]
usb-uhci               26124   0  (unused)
ehci-hcd               20008   0  (unused)
usb-ohci               21544   0  (unused)
usbcore                78752   1  [visor usbserial hid usb-uhci ehci-hcd usb-ohci]
ext3                   71300   8
jbd                    51052   8  [ext3]
lvm-mod                65408  15

 See dmesg:
hub.c: new USB device 00:1f.2-2, assigned address 2
usb.c: USB device 2 (vend/prod 0x830/0x60) is not claimed by any active driver.
usb.c: registered new driver serial
usbserial.c: USB Serial support registered for Generic
usbserial.c: USB Serial Driver core v1.4
usbserial.c: USB Serial support registered for Handspring Visor / Treo / Palm 4.0 / Clie 4.x
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter detected
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter now attached to ttyUSB0 (or usb/tts/0 for devfs)
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter now attached to ttyUSB1 (or usb/tts/1 for devfs)
usbserial.c: USB Serial support registered for Sony Clie 3.5
visor.c: USB HandSpring Visor, Palm m50x, Treo, Sony Clie driver v1.7
usb.c: USB disconnect on device 00:1f.2-2 address 2
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter now disconnected from ttyUSB0
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter now disconnected from ttyUSB1
hub.c: new USB device 00:1f.2-2, assigned address 3
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter detected
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter now attached to ttyUSB0 (or usb/tts/0 for devfs)
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter now attached to ttyUSB1 (or usb/tts/1 for devfs)
usb-uhci.c: interrupt, status 3, frame# 1917
usb.c: USB disconnect on device 00:1f.2-2 address 3
visor.c: Bytes In = 0  Bytes Out = 0
Unable to handle kernel NULL pointer dereference at virtual address 00000998
 printing eip:
e0dff6bc
*pde = 1eb25067
*pte = 00000000
Oops: 0002
visor usbserial ipx floppy ide-cd cdrom cmpci gameport soundcore parport_pc lp parport autofs e100 microcode loop keybdev mousedev hid input usb-uhci ehci-hcd
CPU:    0
EIP:    0060:[<e0dff6bc>]    Not tainted
EFLAGS: 00010246

EIP is at usb_serial_disconnect [usbserial] 0x6c (2.4.22-1.2132.nptl)
eax: 00000000   ebx: d13fdc00   ecx: 00000000   edx: 00000000
esi: d13fdc1c   edi: 00000000   ebp: d13fdc00   esp: df215f14
ds: 0068   es: 0068   ss: 0068
Process khubd (pid: 64, stackpage=df215000)
Stack: d13fdc1c 00000000 00000064 e0e014e0 e0e014c0 00000000 d164a340 e0cc232f
       dfd06c00 d13fdc00 dfd06c04 00000003 00000000 dfd06c00 00000100 0000000a
       df963200 00000001 e0cc5260 df963310 00000002 00000010 df963200 e0cc4c8c
Call Trace:   [<e0e014e0>] usb_serial_driver [usbserial] 0x20 (0xdf215f20)
[<e0e014c0>] usb_serial_driver [usbserial] 0x0 (0xdf215f24)
[<e0cc232f>] usb_disconnect_R3e907b02 [usbcore] 0x9f (0xdf215f30)
[<e0cc5260>] usb_hub_port_connect_change [usbcore] 0x270 (0xdf215f5c)
[<e0cc4c8c>] usb_hub_port_status [usbcore] 0x6c (0xdf215f70)
[<e0cc5558>] usb_hub_events [usbcore] 0x2e8 (0xdf215f90)
[<e0cc55f5>] usb_hub_thread [usbcore] 0x45 (0xdf215fbc)
[<e0cc55b0>] usb_hub_thread [usbcore] 0x0 (0xdf215fc4)
[<e0cc55b0>] usb_hub_thread [usbcore] 0x0 (0xdf215fe0)
[<c010734d>] kernel_thread_helper [kernel] 0x5 (0xdf215ff0)


Code: 89 90 98 09 00 00 8d 4e 58 ff 43 74 0f 8e b5 04 00 00 0f b6
 <4>usb-uhci.c: interrupt, status 3, frame# 804


Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2132.nptl

How reproducible:
Always

Steps to Reproduce:
1.Set up your kpilot or jpilot to deal with /dev/ttyUSB0
2.Insert Tungsten into USB
3.Try to sync by kpilot or jpilot    

Actual Results:  kpilot freeses. visor.o can not be removed from kernel

Expected Results:  sync with kpilot

Additional info:
Comment 1 Pete Zaitcev 2003-12-16 12:27:37 EST
ftp://people.redhat.com/zaitcev/tmp/
 kernel*-2.4.22-1.2130.2.3.nptl*.rpm

Please test.
Comment 2 Andrey Bondarenko 2003-12-17 02:09:50 EST
Great! I had tested and found it works fine. Hope this fix soon will 
be in test branch (bthw, when?).  
 
dmesg: 
 
hub.c: new USB device 02:04.1-1, assigned address 7 
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter 
detected 
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter 
now attached to ttyUSB0 (or usb/tts/0 for devfs) 
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter 
now attached to ttyUSB1 (or usb/tts/1 for devfs) 
visor.c: Bytes In = 57642  Bytes Out = 11793 
usb.c: USB disconnect on device 02:04.1-1 address 7 
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter 
now disconnected from ttyUSB0 
usbserial.c: Handspring Visor / Treo / Palm 4.0 / Clie 4.x converter 
now disconnected from ttyUSB1 
 
Comment 3 Pete Zaitcev 2003-12-17 12:07:14 EST
Thanks a lot for the test. I submitted the patch to Dave Jones,
he will put it into the queue. This will probably take about
2 or 3 weeks, riding the QA bandwidth.
Comment 4 Pete Zaitcev 2003-12-23 16:21:52 EST
Bug 107929 went modified, now duping.


*** This bug has been marked as a duplicate of 107929 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:00:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.