Bug 1122159 - System will not resume from suspend
Summary: System will not resume from suspend
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 16:34 UTC by Giovanni Campagna
Modified: 2015-01-28 08:10 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-28 08:10:13 UTC


Attachments (Terms of Use)
First oops (4.08 MB, image/jpeg)
2014-07-22 16:36 UTC, Giovanni Campagna
no flags Details
Second oops (4.12 MB, image/jpeg)
2014-07-22 16:38 UTC, Giovanni Campagna
no flags Details
First oops (3.77 MB, image/jpeg)
2014-07-31 13:31 UTC, Giovanni Campagna
no flags Details
Second oops (2.17 MB, image/jpeg)
2014-07-31 13:31 UTC, Giovanni Campagna
no flags Details
Third oops (2.37 MB, image/jpeg)
2014-07-31 13:32 UTC, Giovanni Campagna
no flags Details

Description Giovanni Campagna 2014-07-22 16:34:32 UTC
Description of problem:
Everytime I suspend, at resume the system deadlocks completely.
If done from a console, I see a number of oopses.

Even though the system is not panicked, and after 10-20 seconds more oopses appear (including an NMI), no attempt to regain control of the system is effective, including magic sysrq (all enabled).

Version-Release number of selected component (if applicable):
3.16.0-0.rc5.git1.1.fc21.x86_64 (but all F21 kernels since branching are affected)

How reproducible:
Always

Steps to Reproduce:
1. Suspend
2. Resume

Additional info:
Laptop is a Dell Latitude E6400.
I don't know which HW is at fault here, I'll provide more details if needed.

Comment 1 Giovanni Campagna 2014-07-22 16:36:36 UTC
Created attachment 919963 [details]
First oops

Comment 2 Giovanni Campagna 2014-07-22 16:38:36 UTC
Created attachment 919964 [details]
Second oops

Comment 3 Josh Boyer 2014-07-24 15:07:02 UTC
Hm.  Both of those photos are missing the top of the oops.  Is it stored in your logs/journal somewhere?  If not, can you use the pause_on_oops parameter to get a picture that contains the top of the first oops.

Comment 4 Giovanni Campagna 2014-07-31 13:29:59 UTC
The system is fully deadlocked (does not react to sysrq) so I cannot flush the journal to disk and unmount cleanly.

Attached are oops with pause_on_oops turned on.

Comment 5 Giovanni Campagna 2014-07-31 13:31:02 UTC
Created attachment 922931 [details]
First oops

This time it's 3.16.0-0.rc7.git0.1.fc21.x86_64

Comment 6 Giovanni Campagna 2014-07-31 13:31:54 UTC
Created attachment 922932 [details]
Second oops

Comment 7 Giovanni Campagna 2014-07-31 13:32:38 UTC
Created attachment 922933 [details]
Third oops

Comment 8 Justin M. Forbes 2015-01-27 15:00:36 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There are a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 21 kernel bugs.

Fedora 21 has now been rebased to 3.18.3-201.fc21.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 9 Giovanni Campagna 2015-01-28 08:10:13 UTC
This was fixed with 3.17 I think, should be closed.


Note You need to log in before you can comment on or make changes to this bug.