Bug 1122260 - Unable to install local rpms without an internet connection
Summary: Unable to install local rpms without an internet connection
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-22 19:42 UTC by Chris Murphy
Modified: 2014-08-28 05:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-28 05:58:27 UTC


Attachments (Terms of Use)

Description Chris Murphy 2014-07-22 19:42:55 UTC
Description of problem: Lacking an internet connection, but with locally available rpms, dnf won't attempt an installation.


Version-Release number of selected component (if applicable):
dnf-0.5.3-1.fc21.noarch
hawkey-0.4.17-1.fc21.x86_64


How reproducible:
Apparently only happens when dnf considers the cache stale, and insists on updating it first. If I do this:
a.) supply an internet connection and it updates its cache,
b.) decline installation of rpms, quitting dnf,
c.) disconnect internet,
d.) rerun the dnf install command, it works.

Steps to Reproduce:
1. dnf install *rpm
2.
3.

Actual results:

Error: Failed to synchronize cache for repo 'rawhide' from 'https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=x86_64': Cannot prepare internal mirrorlist: Curl error: Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=rawhide&arch=x86_64


Expected results:

Seems like I should be able to install these rpms.


Additional info:
*rpm = 
kernel-core-3.16.0-0.rc5.git0.1.fc21.x86_64.rpm
kernel-modules-3.16.0-0.rc5.git0.1.fc21.x86_64.rpm
kernel-3.16.0-0.rc5.git0.1.fc21.x86_64.rpm

Comment 1 Ales Kozumplik 2014-07-23 05:56:28 UTC
Chris, exactly what you want to do is possible with the '-C' switch. Can you please try it? Thanks!

Comment 2 Chris Murphy 2014-08-28 03:42:35 UTC
It works.

Comment 3 Ales Kozumplik 2014-08-28 05:58:27 UTC
In that case this is not a bug: if DNF is not instructed otherwise it always wants to see the latest metadata in case a dependency for the local RPMs was needed.


Note You need to log in before you can comment on or make changes to this bug.