Bug 1122458 - [Dist-geo-rep] : There is no way to find out the geo-rep session is a mount-broker setup from geo-rep status output.
Summary: [Dist-geo-rep] : There is no way to find out the geo-rep session is a mount-b...
Keywords:
Status: CLOSED DUPLICATE of bug 1104112
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Bug Updates Notification Mailing List
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 10:09 UTC by Vijaykumar Koppad
Modified: 2014-08-25 00:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 06:25:10 UTC


Attachments (Terms of Use)

Description Vijaykumar Koppad 2014-07-23 10:09:48 UTC
Description of problem: There is no way to find out the geo-rep session is a mount-broker setup from geo-rep status. Just by running the command "gluster v geo stat" its not possible to know the session is geo-rep mount-broker, unless complete master and slave url is used like this "gluster v geo {master} {user}@{ slave-node}::{slave-vol} status"

for both the status is same like
=======================================================================
MASTER NODE               MASTER VOL    MASTER BRICK          SLAVE                  STATUS     CHECKPOINT STATUS    CRAWL STATUS
-------------------------------------------------------------------------------------------------------------------------------------
Willard.blr.redhat.com    master        /bricks/brick1/b1     10.70.42.169::slave    Active     N/A                  Changelog Crawl
Willard.blr.redhat.com    master        /bricks/brick2/b5     10.70.42.169::slave    Active     N/A                  Changelog Crawl
Willard.blr.redhat.com    master        /bricks/brick3/b9     10.70.42.169::slave    Active     N/A                  Changelog Crawl
Normand.blr.redhat.com    master        /bricks/brick1/b4     10.70.42.250::slave    Passive    N/A                  N/A
Normand.blr.redhat.com    master        /bricks/brick2/b8     10.70.42.250::slave    Passive    N/A                  N/A
Normand.blr.redhat.com    master        /bricks/brick3/b12    10.70.42.250::slave    Passive    N/A                  N/A
Arnoldo.blr.redhat.com    master        /
========================================================================


Version-Release number of selected component (if applicable): glusterfs-3.6.0.25-1.el6rhs


How reproducible: Happens everytime.


Steps to Reproduce:
1. create and start a geo-rep mount-broker setup
2. after a week run just the command "gluster v geo status " and try to find whether its mount-broker setup or normal setup.

Actual results:  no way to find out the geo-rep session is a mount-broker setup from geo-rep status output.


Expected results: Its the job of status command to show such information. 
 

Additional info:

Comment 2 Aravinda VK 2014-07-24 06:25:10 UTC

*** This bug has been marked as a duplicate of bug 1104112 ***


Note You need to log in before you can comment on or make changes to this bug.