Bug 112256 - [PATCH] hig and layout changes
[PATCH] hig and layout changes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: authconfig (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
Brian Brock
: ScreenshotChange, StringChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-16 14:01 EST by Jens Knutson
Modified: 2013-07-02 18:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 09:27:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
updated glade file (104.10 KB, application/octet-stream)
2003-12-16 14:02 EST, Jens Knutson
no flags Details
proper diff patch for my hig and layout changes (90.04 KB, patch)
2003-12-16 19:15 EST, Jens Knutson
no flags Details | Diff

  None (edit)
Description Jens Knutson 2003-12-16 14:01:16 EST
Summary of the patch
-----------------------

* changed all spacings to proper hig numbers, changed all frames to
the new "whacky packy" style frames, with vboxes and hboxes

* added colons where appropriate to GtkLabels

* removed all seperators from dialog boxes

* changed "joinsave" dialog quite a bit - removed title, changed
button order, removed the icon from "don't save" button, changed text
inside dialog to divide into primary and secondary text, changed icon
to Warning instead of Question

* removed unnecessary "inline help" - if an admin doesn't know what
this stuff is already, s/he won't know learn enough to properly use
the tool from the 2 sentence help provided them in the middle of the
authconfig window. ;)


possible b0rkage due to this change:
------------------------------------

not sure why, but winbind used to be hidden on my system when the
using old, unmodified config dialog, but now it appears.  Also, when I
click the button for configuring winbind, nothing happens...

requests:
---------

* How about a Help button? :)

* In further changes, I'd like to merge the Authentication and User
Info tabs, since some of them otherwise appear twice (a Bad Thing,
IMHO), and again, if an admin doesn't know the difference between some
of these options, s/he's already lost - dividing them up won't help any.

* Could we grey out/disable the "configure" buttons for stuff that's
not enabled in the first place?  ie: if SMB auth isn't checked, the
button should be greyed out.  Doing this would help with the above
mentioned further layout changes...
Comment 1 Jens Knutson 2003-12-16 14:02:59 EST
Created attachment 96561 [details]
updated glade file

sorry this isn't a diff - I'm posting this from a 'net cafe. it's a long story.
;)
Comment 2 Jens Knutson 2003-12-16 19:15:14 EST
Created attachment 96574 [details]
proper diff patch for my hig and layout changes

Ok, here's a real diff this time - obsoleting the original attachment.	Sorry
for the spam.
Comment 3 Nalin Dahyabhai 2003-12-17 15:41:08 EST
Thanks for the patch!

Some notes, though: a help button won't help much until there's help
text to go with it, and there currently is none.  I'd love for that to
change.

The User Information and Authentication tabs are separate because
items which appear in both places frequently control different things
(for example, LDAP for user information turns on use of nss_ldap, and
LDAP for authentication turns on pam_ldap -- you can use one without
the other).

Configuration buttons are already made insensitive when the mechanism
which they configure is not enabled, so I'm a bit confused.  You're
certain that you're using the development tree's version of authconfig
and authconfig-gtk on your system?

Are the buttons in the new wacky-packy layout supposed to not line up?
Comment 4 Jindrich Novy 2004-09-14 09:27:10 EDT
Hi Jens,

I modified interface of authconfig to two column style to fit lower
resolution screens and modified keyboard shortcuts. If you want to try
it out, please get authconfig-4.6.4-3 (rawhide). Any comments are
welcome. Because the request made here is rather old, I'll close this
bug. If you have any suggestions concerning the new interface, please
don't hesitate to create a new "enhancement" authconfig "bug". Thanks
again!

Jindrich

Note You need to log in before you can comment on or make changes to this bug.