Bug 1122654 - [patch] epydoc: don't put timestamp in html files
Summary: [patch] epydoc: don't put timestamp in html files
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: epydoc
Version: 21
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Othman Madjoudj
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 17:14 UTC by Benedikt Morbach
Modified: 2015-10-02 22:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-02 22:19:55 UTC


Attachments (Terms of Use)
patch to prevent timestamp in docs (6.60 KB, patch)
2014-07-23 17:14 UTC, Benedikt Morbach
no flags Details | Diff

Description Benedikt Morbach 2014-07-23 17:14:48 UTC
Created attachment 920323 [details]
patch to prevent timestamp in docs

Description of problem:
epydoc adds a timestamp to the footer of the html files it generates.
This is pretty much useless, but causes unnecessary noise and prevents the build from being easily reproducible. (If I build from the same srpm twice, I get different results)

The attached patch prevents this timestamp from being added and adds an '--include-timestamp' argument, in case anyone does indeed need it.

The patch was submitted to upstream here: (even though upstream seems dead)
https://sourceforge.net/p/epydoc/patches/26/

Note that upstream added a '--supress-timestamp' option in svn, but didn't do a release with that, so the patches differ.

I decided to change the default, because otherwise we would have to change every package that uses epydoc.

Comment 2 Fedora Admin XMLRPC Client 2015-09-30 19:19:57 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 3 Fedora Admin XMLRPC Client 2015-09-30 20:01:28 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 4 Othman Madjoudj 2015-10-02 22:19:55 UTC
Fixed in rawhide, let me know if we need the fixes in the other branches.

http://koji.fedoraproject.org/koji/taskinfo?taskID=11314379


Note You need to log in before you can comment on or make changes to this bug.