Bug 1122669 - Mod_snmp won't compile on ppc64
Summary: Mod_snmp won't compile on ppc64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Apache Server (httpd) and Connectors
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: DR9
: EAP 6.4.0
Assignee: Permaine Cheung
QA Contact: Michal Karm Babacek
URL:
Whiteboard:
: 1122668 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-23 18:09 UTC by Permaine Cheung
Modified: 2019-08-19 12:44 UTC (History)
3 users (show)

Doc Type: Known Issue
Doc Text:
In this release of JBoss EAP 6, mod_snmp libraries will not be provided for PPC64 platform (RHEL6, RHEL7).
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)
patch for the issue. (91.80 KB, text/plain)
2014-09-04 06:43 UTC, Jean-frederic Clere
no flags Details

Description Permaine Cheung 2014-07-23 18:09:48 UTC
During the build of mod_snmp on ppc64, it currently failed with:

configure: error: cannot guess build type; you must specify one
make: *** No targets specified and no makefile found.  Stop.

As you mentioned, the configure/libtool and corresponding files in the mod_snmp-2.4.1.GA/snmp_common/* need to be ported to ppc64/rhel6/7.


This needs to be documented if we couldn't get it EAP 6.3.0.

Comment 1 Permaine Cheung 2014-07-23 18:24:41 UTC
I meant this needs to be documented as a known issue if we couldn't get it EAP 6.3.0.

Comment 2 Jean-frederic Clere 2014-07-24 11:21:49 UTC
The source code needs porting some system call (or libc functions) need to ported.
For example:
getsockname() on ppc64 doesn't seem to correctly not sure that porting that old code is worth it....

Comment 4 Jean-frederic Clere 2014-07-30 07:44:03 UTC
There isn't a reason to document the internal problem...
Basically there should be another issue telling that mod_snmp libraries are missing on ppc64 and other other issue should depend on this one.

Comment 7 Jan Stefl 2014-08-20 07:21:16 UTC
*** Bug 1122668 has been marked as a duplicate of this bug. ***

Comment 9 Jean-frederic Clere 2014-09-04 06:43:41 UTC
Created attachment 934291 [details]
patch for the issue.

Comment 10 Jan Stefl 2014-11-06 10:29:34 UTC
Could you tell me what is a current status of this?

Comment 11 Permaine Cheung 2014-11-06 13:52:52 UTC
Weinan has built with the patch provided, and libraries are included in 6.4.0 DR8. Marking as ON_QA.

Comment 12 Michal Karm Babacek 2014-11-14 14:13:35 UTC
The original segfault error is gone, snmp module is up and running on ppc64 boxes:

> RHEL7 PPC64
> Apache/2.2.26 (Unix) DAV/2 CovalentSNMP/2.3.0 mod_ssl/2.2.26 OpenSSL/1.0.1e-fips configured -- resuming normal operations
> SNMP: CovalentSNMP/2.3.0 started (user '0' - SNMP address '1610' - pid '10631')

> RHEL6 PPC64
> Apache/2.2.26 (Unix) DAV/2 CovalentSNMP/2.3.0 mod_ssl/2.2.26 OpenSSL/1.0.1e-fips configured -- resuming normal operations
> SNMP: CovalentSNMP/2.3.0 started (user '0' - SNMP address '1610' - pid '5849')

Thanks.


Note You need to log in before you can comment on or make changes to this bug.