Bug 1122838 - [Doc Bug Fix] Enhance example of Sybase XA datasource to contain info about is-same-rm-override
Summary: [Doc Bug Fix] Enhance example of Sybase XA datasource to contain info about i...
Keywords:
Status: CLOSED DUPLICATE of bug 1185398
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: post-GA
: ---
Assignee: eap-docs
QA Contact: Ondrej Chaloupka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 08:09 UTC by Ondrej Chaloupka
Modified: 2015-02-24 08:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-24 08:41:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Ondrej Chaloupka 2014-07-24 08:09:38 UTC
Hi,

I would like ask to add note to section:
Example Sybase XA Datasource
https://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html/Administration_and_Configuration_Guide/Example_Sybase_XA_Datasource.html

where is example of configuration fo XA datasource for Sybase.

The note should contain information that customer should consider setting 
is-same-rm-override set to false (for setting see e.g. example of Example Oracle XA Datasource - <is-same-rm-override>false</is-same-rm-override>)
when he uses several datasources which point to the same Sybase database but with different account inside of one XA transaction. In such case Sybase driver marks such connections to be joined to one transaction branch and it could cause the transaction gets hanged. So the solution is to force transaction manager to create separate branch for each connection. A disadvantage of such approach is that performance could be harmed.

Comment 1 Ondrej Chaloupka 2015-02-24 08:41:22 UTC

*** This bug has been marked as a duplicate of bug 1185398 ***


Note You need to log in before you can comment on or make changes to this bug.