Bug 1122853 - mojomojo-1.10-4.fc22 FTBFS: missing trailing slash in t/formatter_file.t test
Summary: mojomojo-1.10-4.fc22 FTBFS: missing trailing slash in t/formatter_file.t test
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mojomojo
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://github.com/mojomojo/mojomojo/...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 08:35 UTC by Petr Pisar
Modified: 2014-07-24 10:58 UTC (History)
2 users (show)

Fixed In Version: mojomojo-1.10-5.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 10:58:48 UTC


Attachments (Terms of Use)

Description Petr Pisar 2014-07-24 08:35:50 UTC
mojomojo-1.10-4.fc22 fails to build do to tests:

t/formatter_docbook.t ........... ok
#   Failed test 'Text file is formated'
#   at t/formatter_file.t line 51.
#                   '<div class="formatter_txt">
# <p>Text file</p> <p><a href="http://mojomojo.org">http://mojomojo.org</a></p></div>
# '
#     doesn't match '(?^s:<div class="formatter_txt">\n<p>Text file</p> <p><a href="http://mojomojo.org/">http://mojomojo.org</a></p></div>)'
# Looks like you failed 1 test of 14.
t/formatter_file.t .............. 

The trailing slash is missing in the URL.

Comment 1 Petr Pisar 2014-07-24 09:03:00 UTC
This is caused by upgrading from perl-URI-Find-20140702-1.fc21 to perl-URI-Find-20140709-1.fc22.

Comment 2 Petr Pisar 2014-07-24 09:08:14 UTC
From URI-Find changelog:

20140709  Wed Jul  9 16:28:37 PDT 2014
    Backwards Incompatibilities
    * Previously, URIs stringified to their canonical version.  Now
      they stringify as written.  This results in less loss of
      information.  For example.  "Blah HTTP:://FOO.COM" previously
      would stringify as "http://foo.com/" and now it will stringify
      as "HTTP://FOO.COM".  To restore the old behavior you can call
      $uri->canonical. (Schwern)

Comment 3 Petr Pisar 2014-07-24 09:15:20 UTC
Reported to upstream <https://github.com/mojomojo/mojomojo/issues/122>.

Comment 4 Petr Pisar 2014-07-24 09:33:46 UTC
I will just adjust the test leaving finale decision to upstream. I don't know whether canonizing URIs was in intention, or just an side effect.


Note You need to log in before you can comment on or make changes to this bug.