Bug 1122856 - ambiguous nodes: the queue is removed by exchange removal request
Summary: ambiguous nodes: the queue is removed by exchange removal request
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid
Version: Development
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Gordon Sim
QA Contact: Valiantsina Hubeika
URL:
Whiteboard:
Depends On:
Blocks: 1151983
TreeView+ depends on / blocked
 
Reported: 2014-07-24 08:48 UTC by Petr Matousek
Modified: 2015-01-04 22:55 UTC (History)
6 users (show)

Fixed In Version: python-qpid-0.22-17
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1151983 (view as bug list)
Environment:
Last Closed: 2014-09-24 15:12:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5923 None None None Never
Red Hat Bugzilla 1122857 None None None Never
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 19:00:06 UTC

Internal Links: 1122857

Description Petr Matousek 2014-07-24 08:48:19 UTC
Description of problem:

Having defined two ambiguous node (queue and exchange of the same name), the queue is deleted by issuing exchange removal request.

Version-Release number of selected component (if applicable):
python-qpid-0.22-15

How reproducible:
100%

Steps to Reproduce:
1. drain  -f "ambiguous_node;{'node': {'type': 'queue'}, 'create': 'receiver'}"
2. drain  -f "ambiguous_node;{'node': {'type': 'topic'}, 'create': 'receiver'}"
3. drain "ambiguous_node;{'node': {'type': 'topic'}, 'delete': 'always'}"
4. The queue was removed instead of the topic (not expected)
5. repeat step 3
6. the exchange is removed (expected)


Actual results:
A queue is removed first when when ambiguous nodes exists regardless of the node type specified in the address string.

Expected results:
Only the node of type defined in the address string is removed when ambiguous nodes exists.

Additional info:

Comment 1 Gordon Sim 2014-07-24 13:54:29 UTC
Fixed upstream: https://svn.apache.org/r1613131

Comment 2 Gordon Sim 2014-07-24 14:00:48 UTC
Oops, actually the fix is https://svn.apache.org/r1613130, the revision above is related but is just adding exclusions for AMQP 1.0 (where delete is not supported).

Comment 7 Valiantsina Hubeika 2014-08-04 14:14:24 UTC
verified on
python-qpid-0.22-17

Comment 8 errata-xmlrpc 2014-09-24 15:12:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html


Note You need to log in before you can comment on or make changes to this bug.