Bug 1122876 - "oo-stats" timeout when no ActiveMQ available
Summary: "oo-stats" timeout when no ActiveMQ available
Keywords:
Status: CLOSED DUPLICATE of bug 1122872
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Luke Meyer
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 09:29 UTC by Miguel Perez Colino
Modified: 2014-07-30 07:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-24 13:39:33 UTC


Attachments (Terms of Use)

Description Miguel Perez Colino 2014-07-24 09:29:53 UTC
Description of problem:
"oo-stats" gets hanged when no ActiveMQ servers are available.

Version-Release number of selected component (if applicable):
OSE 2.1.2
openshift-origin-broker-util-1.23.8.4-1.el6op.noarch

How reproducible:
Stop all ActiveMQ services and run "oo-stats"

Steps to Reproduce:
1. Stop all ActiveMQ services
2. Run "oo-stats" and wait
3. Keep waiting

Actual results:
No error received after some time.

Expected results:
Timeout reached and "oo-stats" exists with error.

Additional info:
Found when using "oo-stats" is usad as part of monitorization and doing resiliency tests.

Comment 2 Luke Meyer 2014-07-24 13:39:33 UTC
Consolidating all "hangs on activemq down" bugs.

*** This bug has been marked as a duplicate of bug 1122872 ***


Note You need to log in before you can comment on or make changes to this bug.