Bug 1122890 - Reposytory synchronization get stucked
Summary: Reposytory synchronization get stucked
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.3
Hardware: x86_64
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 10:12 UTC by Jakub Bittner
Modified: 2017-02-23 21:10 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-05-26 19:45:36 UTC


Attachments (Terms of Use)
foreman-debug (285.40 KB, application/x-xz)
2014-07-24 10:27 UTC, Jakub Bittner
no flags Details

Description Jakub Bittner 2014-07-24 10:12:11 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select time outed/canceled repos
2. Run sync (web/cli)
3. Stucked

Actual results:
Stucked

Expected results:
Synced

Additional info:

I have problem with Fedora 20 repos

Comment 1 RHEL Product and Program Management 2014-07-24 10:14:18 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Tom McKay 2014-07-24 10:18:49 UTC
To better understand the source of the problem, please provide any additional details such as more precise steps to reproduce. Attaching the output of foreman-debug to this BZ will also be necessary. Thanks!

Comment 4 Jakub Bittner 2014-07-24 10:27:01 UTC
Created attachment 920494 [details]
foreman-debug

Comment 5 Jakub Bittner 2014-07-24 10:34:34 UTC
I repodiscovered url "http://mirrors.nic.cz/fedora/linux/updates/20/" and added "http://mirrors.nic.cz/fedora/linux/updates/20/i386/" and "http://mirrors.nic.cz/fedora/linux/updates/20/x86_64/" and added it to product Fedora. There were 2 more previously synchronized repos from fodora os (i386 and x86_64). Both successfully. After that I went to Contetnt -> Sync Status, select newly created Fedora updates repo and clicked on Synchronize Now. 

Than I go home.

Next day, there was empty progress bar, so I canceled it and than tried to synchronize them again. Since than nothing has happened.

Log attached.


It always happened with all repositories. If I cancel them it is not possible to sync them again.

Thanks.

Comment 6 Jakub Bittner 2014-07-30 08:25:16 UTC
I still have stucked fedora synchronization. Server restart did not help. I can synchronize all other repositories. Even if I reschedule stucked repos sync it will not help.

Comment 7 Eric Helms 2015-05-22 13:21:19 UTC
Jakub,

The repositories you have listed in your previous comment, when I browse them through the Web UI, do not appear to be valid repository links (e.g. I am not seeing a repomd.xml anywhere). Are you able to check what the error output or what stage the error occurred at during the repository sync?

Comment 8 Mike McCune 2015-05-26 19:45:36 UTC
Jakub, if you are still using Satellite 6 can you re-attempt this with our latest version?

I was able to discover and create repositories with this url just fine:

http://mirrors.nic.cz/fedora/linux/updates/20/

I'm going to close this as WORKSFORMME but feel free to re-open if you are still seeing this with the latest 6.0.8 or 6.1 Beta versions.

Comment 9 Jakub Bittner 2015-06-22 13:43:00 UTC
Hi,

I can confirm, that synchronization works for me.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.