Bug 112290 - iiimf im module crashes gtk2 applications
Summary: iiimf im module crashes gtk2 applications
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: im-sdk   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Yu Shao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-17 06:17 UTC by Jens Petersen
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-06 19:33:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2003-12-17 06:17:42 UTC
Description of problem:
Switching the gtk IM module to iiimf causes gtk applications
to crash.

Version-Release number of selected component (if applicable):
im-sdk-11_4-2.1

How reproducible:
everytime

Steps to Reproduce:
1. LANG=ja_JP.UTF-8 /usr/lib/im/htt &
2. LANG=ja_JP.UTF-8 /usr/lib/im/httx &
3. LANG=ja_JP.UTF-8 gedit
4. Button-3 popup menu -> Internet/Intranet Input Method

Actual results:
gedit crashes

Expected results:
Should switch to iiimf IM normally.

Additional info:
newpy seems to work the first time, but stops working the second
time with aux_win using all the cpu...

Comment 1 Leon Ho 2004-01-19 23:36:54 UTC
Not sure if it is problem on CannaLE or the IIIMF, please have a look.
Reassign if it is related to the framework.

Comment 2 Leon Ho 2004-01-19 23:48:04 UTC
Look like it is fixed in the truck. Here is my test case:

# /usr/lib/im/htt
# LANG=ja_JP.UTF-8 GTK_IM_MODULE=iiim gedit

It crashes in 11_4-4 rpm but it is okay now.
Please retest with truck.

Comment 3 Lawrence Lim 2004-01-19 23:51:07 UTC
I have no problem testing with Hangul LE (the latest version from svn)

I switched from XIM->IIIMF->XIM->IIIMF. No problem was encountered
during the event.

Comment 5 Jens Petersen 2004-02-06 08:42:14 UTC
I'm seeing consistent crashing of gtk apps with
im-sdk-11.4-7 again as soon as they are switched
into iiimf.

Comment 6 Jens Petersen 2004-02-06 10:56:43 UTC
I tested with the system locale set to ko_KR.UTF-8 too
and gtk apps crash when switched to iiimf too, so re-assigning
this to im-sdk owner.

Comment 7 Yu Shao 2004-02-06 19:33:13 UTC
Will be fixed in next build im-sdk-11.4-8, it is because of gtk
version inconsistent.

Comment 8 Jens Petersen 2004-02-09 04:04:31 UTC
Confirmed, fixed.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.