Bug 1123005 - Rebase to grep-2.20 (or later)
Summary: Rebase to grep-2.20 (or later)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grep
Version: 7.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Jan Kepler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 15:11 UTC by Jaroslav Škarvada
Modified: 2018-12-09 18:13 UTC (History)
4 users (show)

Fixed In Version: grep-2.20-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 10:02:25 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0435 normal SHIPPED_LIVE grep bug fix and enhancement update 2015-03-05 14:38:34 UTC
Red Hat Knowledge Base (Solution) 904243 None None None Never

Description Jaroslav Škarvada 2014-07-24 15:11:17 UTC
Description of problem:
The latest grep-2.20 came with several performance tweaks that improve its performance. For some use cases the performance improvement is drastical. That's why it would be useful to have it in RHEL-7.1. This may improve user experience of cusotmers.

Version-Release number of selected component (if applicable):
grep-2.16-1.el7

How reproducible:
Always

Steps to Reproduce:
1. Check the grep version

Actual results:
grep-2.16-1.el7

Expected results:
grep-2.20-1.el7 or later


Additional info:
The grep-2.20 is in the f21 and f22 for a while and no compatiblity problem have been noticed so far.

Comment 6 James Hartsock 2015-01-29 19:09:52 UTC
Using customer provided example in case 01035621, can clearly see that grep-2.20-1.el7 in RHEL 7.1 beta is much faster than grep-2.16-1.el7 in RHEL 7.0

grep-2.16-1.el7 in RHEL 7.0
~~~
[root@rhel7-0 ~]# cat bgis2.recorded bgis2.serverlist > /dev/null #make sure files in cache
[root@rhel7-0 ~]# rpm -q grep
grep-2.16-1.el7.x86_64
[root@rhel7-0 ~]# time grep -v -f bgis2.recorded bgis2.serverlist
wa95dbx3
real	4m29.203s
user	4m27.642s
sys	0m0.989s
[root@rhel7-0 ~]# time fgrep -v -f bgis2.recorded bgis2.serverlist
wa95dbx3
real	0m0.041s
user	0m0.019s
sys	0m0.005s
~~~



grep-2.20-1.el7 in RHEL 7.1
~~~
[root@rhel7-1 ~]# cat bgis2.recorded bgis2.serverlist > /dev/null #make sure files in cache
[root@rhel7-1 ~]# rpm -q grep
grep-2.20-1.el7.x86_64
[root@rhel7-1 ~]# time grep -v -f bgis2.recorded bgis2.serverlist
wa95dbx3
real	0m22.091s
user	0m21.379s
sys	0m0.660s
[root@rhel7-1 ~]# time fgrep -v -f bgis2.recorded bgis2.serverlist
wa95dbx3
real	0m0.041s
user	0m0.016s
sys	0m0.004s
~~~

Comment 8 errata-xmlrpc 2015-03-05 10:02:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0435.html


Note You need to log in before you can comment on or make changes to this bug.