Bug 1123083 - Repo sync failing when you have global proxy setup
Summary: Repo sync failing when you have global proxy setup
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Pulp
Classification: Retired
Component: rpm-support
Version: 2.4 Beta
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-24 19:35 UTC by Preethi Thomas
Modified: 2014-07-25 10:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-25 10:13:43 UTC


Attachments (Terms of Use)
log for global proxy for rpm and iso (11.25 KB, text/plain)
2014-07-24 19:35 UTC, Preethi Thomas
no flags Details

Description Preethi Thomas 2014-07-24 19:35:16 UTC
Created attachment 920712 [details]
log for global proxy for rpm and iso

Description of problem:

Repo sync fails with global proxy setup

Version-Release number of selected component (if applicable):

[root@qe-blade-04 ~]# rpm -qa pulp-server
pulp-server-2.4.0-0.25.beta.el7.noarch
[root@qe-blade-04 ~]# 

How reproducible:


Steps to Reproduce:
1. setup global proxy
2. Try repo sync
3.

Actual results:
[root@qe-blade-04 ~]# pulp-admin rpm repo sync run --repo-id errata
+----------------------------------------------------------------------+
                   Synchronizing Repository [errata]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.


Downloading metadata...
[-]
... failed

HTTPConnectionPool(host='repos.fedorapeople.org', port=80): Max retries exceeded
with url: /repos/pulp/pulp/demo_repos/test_errata_install/repodata/repomd.xml
(Caused by <class 'socket.error'>: [Errno 111] Connection refused)


Task Failed

Importer indicated a failed response



[root@qe-blade-04 ~]#  pulp-admin iso repo sync run --repo-id file-repo
+----------------------------------------------------------------------+
                  Synchronizing Repository [file-repo]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.


Downloading the Pulp Manifest failed:

	{}


Task Failed

Importer indicated a failed response


Expected results:


Additional info:

Comment 1 Preethi Thomas 2014-07-24 19:39:30 UTC
[root@qe-blade-04 ~]# cat /etc/pulp/server/plugins.conf.d/iso_importer.json 
{
    "num_threads" : 4,
    "proxy_host" : "http://pulp-proxy.usersys.redhat.com",
    "proxy_port" : 8080,
    "proxy_username": "admin",
    "proxy_password": "admin"
}

[root@qe-blade-04 ~]# cat /etc/pulp/server/plugins.conf.d/yum_importer.json 
{
    "num_threads" : 4,
    "proxy_host" : "http://pulp-proxy.usersys.redhat.com",
    "proxy_port" : 8080,
    "proxy_username": "admin",
    "proxy_password": "admin"
}

Comment 2 Michael Hrivnak 2014-07-24 21:47:26 UTC
Since we've seen today that repos.fedorapeople.org is no longer serving content on port 80 and that it's been down completely for part of the day, can you reproduce this with a repo that is served reliably on port 80? Here's a nice small one if you're looking for options:

http://yum.puppetlabs.com/el/7/dependencies/x86_64/

Comment 3 Preethi Thomas 2014-07-25 10:13:43 UTC
Retested both the iso & yum repos and both synced with no error

[root@qe-blade-04 ~]# pulp-admin rpm repo create --repo-id global-proxy --feed http://yum.puppetlabs.com/el/7/dependencies/x86_64/
Successfully created repository [global-proxy]

[root@qe-blade-04 ~]#  pulp-admin rpm repo sync run --repo-id global-proxy
+----------------------------------------------------------------------+
                Synchronizing Repository [global-proxy]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.


Downloading metadata...
[|]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       9/9 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed


Task Succeeded



Initializing repo metadata
[-]
... completed

Publishing Distribution files
[-]
... completed

Publishing RPMs
[==================================================] 100%
9 of 9 items
... completed

Publishing Delta RPMs
... skipped

Publishing Errata
[-]
... completed

Publishing Comps file
[-]
... completed

Publishing Metadata.
[-]
... completed

Closing repo metadata
[-]
... completed

Generating sqlite files
... skipped

Publishing files to web
[-]
... completed

Writing Listings File
[-]
... completed


Task Succeeded


Note You need to log in before you can comment on or make changes to this bug.