Bug 1123174 - IOError: [Errno 28] No space left on device: '/mnt/sysimage/etc/fstab'
Summary: IOError: [Errno 28] No space left on device: '/mnt/sysimage/etc/fstab'
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:27e8b81bec994eef3a15eb6c4f7...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 04:33 UTC by lwgarmstrong
Modified: 2014-09-04 14:53 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-04 14:53:47 UTC


Attachments (Terms of Use)
File: anaconda-tb (3.52 MB, text/plain)
2014-07-25 04:38 UTC, lwgarmstrong
no flags Details
File: anaconda.log (410.24 KB, text/plain)
2014-07-25 04:39 UTC, lwgarmstrong
no flags Details
File: environ (517 bytes, text/plain)
2014-07-25 04:39 UTC, lwgarmstrong
no flags Details
File: journalctl (1.27 MB, text/plain)
2014-07-25 04:39 UTC, lwgarmstrong
no flags Details
File: lsblk_output (3.56 KB, text/plain)
2014-07-25 04:39 UTC, lwgarmstrong
no flags Details
File: nmcli_dev_list (12.02 KB, text/plain)
2014-07-25 04:39 UTC, lwgarmstrong
no flags Details
File: os_info (375 bytes, text/plain)
2014-07-25 04:40 UTC, lwgarmstrong
no flags Details
File: program.log (578.86 KB, text/plain)
2014-07-25 04:40 UTC, lwgarmstrong
no flags Details
File: storage.log (1.31 MB, text/plain)
2014-07-25 04:41 UTC, lwgarmstrong
no flags Details
File: ifcfg.log (3.70 KB, text/plain)
2014-07-25 04:41 UTC, lwgarmstrong
no flags Details
File: packaging.log (110 bytes, text/plain)
2014-07-25 04:41 UTC, lwgarmstrong
no flags Details

Description lwgarmstrong 2014-07-25 04:33:49 UTC
Description of problem:
Python Install Error

Version-Release number of selected component:
anaconda-20.25.15-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.25.15-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2800, in write
    open(fstab_path, "w").write(fstab)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1670, in write
    self.fsset.write()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 165, in doInstall
    storage.write()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 192, in run
    threading.Thread.run(self, *args, **kwargs)
IOError: [Errno 28] 设备上没有空间: '/mnt/sysimage/etc/fstab'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=initrd0.img root=live:CDLABEL=FEDORA rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
other involved packages: python-blivet-0.23.9-1.fc20.noarch, python-libs-2.7.5-9.fc20.x86_64
product:        Fedora
release:        Fedora release 20 (Heisenbug)
type:           anaconda
version:        20

Potential duplicate: bug 906018

Comment 1 lwgarmstrong 2014-07-25 04:38:54 UTC
Created attachment 920782 [details]
File: anaconda-tb

Comment 2 lwgarmstrong 2014-07-25 04:39:29 UTC
Created attachment 920783 [details]
File: anaconda.log

Comment 3 lwgarmstrong 2014-07-25 04:39:30 UTC
Created attachment 920784 [details]
File: environ

Comment 4 lwgarmstrong 2014-07-25 04:39:55 UTC
Created attachment 920785 [details]
File: journalctl

Comment 5 lwgarmstrong 2014-07-25 04:39:57 UTC
Created attachment 920786 [details]
File: lsblk_output

Comment 6 lwgarmstrong 2014-07-25 04:39:58 UTC
Created attachment 920787 [details]
File: nmcli_dev_list

Comment 7 lwgarmstrong 2014-07-25 04:40:00 UTC
Created attachment 920788 [details]
File: os_info

Comment 8 lwgarmstrong 2014-07-25 04:40:20 UTC
Created attachment 920789 [details]
File: program.log

Comment 9 lwgarmstrong 2014-07-25 04:41:00 UTC
Created attachment 920790 [details]
File: storage.log

Comment 10 lwgarmstrong 2014-07-25 04:41:02 UTC
Created attachment 920791 [details]
File: ifcfg.log

Comment 11 lwgarmstrong 2014-07-25 04:41:03 UTC
Created attachment 920792 [details]
File: packaging.log

Comment 12 Germano Massullo 2014-07-28 16:55:33 UTC
I was installing Fedora when I got the error message

cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   initrd=/Fedora-Live-KDE-x86_64-20-1/isolinux/initrd0.img root=live:CDLABEL=Multi-Boot live_dir=/Fedora-Live-KDE-x86_64-20-1/LiveOS/ rootfstype=auto ro rd.live.image quiet rhgb rd.luks=0 rd.md=0 rd.dm=0 BOOT_IMAGE=/Fedora-Live-KDE-x86_64-20-1/isolinux/vmlinuz0 
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
other involved packages: python-blivet-0.23.9-1.fc20.noarch, python-libs-2.7.5-9.fc20.x86_64
package:        anaconda-20.25.15-1.fc20.x86_64
packaging.log:  14:48:36,082 INFO packaging: rsync exited with code 11
product:        Fedora
reason:         IOError: [Errno 30] File system in sola lettura: '/mnt/sysimage/etc/fstab'
release:        Fedora release 20 (Heisenbug)
version:        20

Comment 13 Germano Massullo 2014-07-29 01:33:02 UTC
I can reproduce the bug with Live respin ISO too.

Comment 14 Kevin Kofler 2014-07-29 02:18:18 UTC
I changed the subject to the English version of errno 28 (No space left on device). Errno 30 is "Read-only file system" in English. In both cases, writing /etc/fstab is failing, but for different reasons. Anaconda reacts with a crash at the same line of code.

Comment 15 Germano Massullo 2014-07-29 07:46:11 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1103712#c13

Comment 16 Germano Massullo 2014-08-03 09:40:12 UTC
My problem was originated by an incompatibility between computer's SATA controller and the SSD drive, so please ignore my comments and logs.

Comment 17 David Shea 2014-09-04 14:53:47 UTC
It looks like you are creating a 2MB / partition. That is way too small.


Note You need to log in before you can comment on or make changes to this bug.