Bug 1123194 - Ubuntu14.04 guest: packet loss when ping from host
Summary: Ubuntu14.04 guest: packet loss when ping from host
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Ronen Hod
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 05:51 UTC by CongLi
Modified: 2014-12-15 00:54 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 15:04:12 UTC


Attachments (Terms of Use)

Description CongLi 2014-07-25 05:51:59 UTC
Description of problem:
Ubuntu14.04 guest: packet loss when ping from host 

ping guest(10.66.110.218) from host:
# ping 10.66.110.218 -s 100
PING 10.66.110.218 (10.66.110.218) 100(128) bytes of data.
108 bytes from 10.66.110.218: icmp_seq=28 ttl=64 time=1.64 ms
108 bytes from 10.66.110.218: icmp_seq=29 ttl=64 time=0.213 ms
108 bytes from 10.66.110.218: icmp_seq=30 ttl=64 time=0.193 ms
108 bytes from 10.66.110.218: icmp_seq=31 ttl=64 time=0.210 ms
108 bytes from 10.66.110.218: icmp_seq=32 ttl=64 time=0.210 ms
108 bytes from 10.66.110.218: icmp_seq=33 ttl=64 time=0.208 ms
108 bytes from 10.66.110.218: icmp_seq=34 ttl=64 time=0.208 ms
^C
--- 10.66.110.218 ping statistics ---
34 packets transmitted, 7 received, 79% packet loss, time 33301ms
rtt min/avg/max/mdev = 0.193/0.411/1.641/0.502 ms

Version-Release number of selected component (if applicable):
kernel-2.6.32-491.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.430.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Boot Ubuntu.14.04.x86_64 guest with e1000 nic:
    -device e1000,mac=9a:f8:f9:fa:fb:fc,id=idgKiUUd,netdev=id3W9njz,bus=pci.0,addr=06  \
    -netdev tap,id=id3W9njz,vhost=on  \

2. check the guest IP 

3. ping the guest from host side
# ping 10.66.110.218 -s 100

Actual results:
packet loss:
--- 10.66.110.218 ping statistics ---
34 packets transmitted, 7 received, 79% packet loss, time 33301ms
rtt min/avg/max/mdev = 0.193/0.411/1.641/0.502 ms

Expected results:
no packet loss when ping

Additional info:
1. also met this problem with i386 guest.

2. virtio_net and rtl8139 also can met this problem
    -device virtio-net-pci,mac=9a:f8:f9:fa:fb:fc,id=idgKiUUd,netdev=id3W9njz,bus=pci.0,addr=06  \
    -netdev tap,id=id3W9njz,vhost=on  \

    -device rtl8139,mac=9a:f8:f9:fa:fb:fc,id=idgKiUUd,netdev=id3W9njz,bus=pci.0,addr=06  \
    -netdev tap,id=id3W9njz,vhost=on  \

3. QEMU CML:
/usr/bin/qemu-kvm \
    -S  \
    -name 'virt-tests-vm1' \
    -M rhel6.6.0  \
    -nodefaults  \
    -vga cirrus \
    -device AC97,bus=pci.0,addr=03  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20140724-153431-Iy2wRG6f,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20140724-153431-Iy2wRG6f,server,nowait \
    -device isa-serial,chardev=serial_id_serial0  \
    -chardev socket,id=seabioslog_id_20140724-153431-Iy2wRG6f,path=/tmp/seabios-20140724-153431-Iy2wRG6f,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20140724-153431-Iy2wRG6f,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=04 \
    -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,file=/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/ubuntu-14.04-server-64-virtio.qcow2 \
    -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=0,bus=pci.0,addr=05 \
    -device rtl8139,mac=9a:f8:f9:fa:fb:fc,id=idgKiUUd,netdev=id3W9njz,bus=pci.0,addr=06  \
    -netdev tap,id=id3W9njz,vhost=on  \
    -m 4096  \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2  \
    -cpu 'Opteron_G4' \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :0  \
    -rtc base=utc,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off  \
    -no-kvm-pit-reinjection \
    -enable-kvm \
    -monitor stdio

4. host info:
processor	: 23
vendor_id	: AuthenticAMD
cpu family	: 21
model		: 1
model name	: AMD Opteron(TM) Processor 6234                 
stepping	: 2
cpu MHz		: 2400.151
cache size	: 2048 KB
physical id	: 1
siblings	: 12
core id		: 5
cpu cores	: 6
apicid		: 75
initial apicid	: 43
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nonstop_tsc extd_apicid amd_dcm aperfmperf pni pclmulqdq monitor ssse3 cx16 sse4_1 sse4_2 popcnt aes xsave avx lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 nodeid_msr topoext perfctr_core cpb npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold
bogomips	: 4799.74
TLB size	: 1536 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb

Comment 3 CongLi 2014-07-29 03:00:31 UTC
(In reply to Ronen Hod from comment #2)
> Since the guest is Ubuntu (not a supported guest, I believe), and I suspect
> that it is not a regression, I am not sure how we want to proceed.
> CongLi, can you try to reproduce with the latest RHEL7 host?

Hi Ronen,

This bug can't be reproduced on RHEL.7.1 host in the following versions:

kernel-3.10.0-138.el7.x86_64
qemu-kvm-1.5.3-66.el7.x86_64

Thanks,
Cong


Note You need to log in before you can comment on or make changes to this bug.