Bug 1123297 - middle-click not supported by gesture on T440
Summary: middle-click not supported by gesture on T440
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-synaptics
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-25 09:14 UTC by Tomas Pelka
Modified: 2015-03-05 08:30 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-drv-synaptics-1.7.1-12.el7
Doc Type: Bug Fix
Doc Text:
Cause: The synaptics driver code would sometimes interpret three-finger taps as two-finger taps depending on the order in which touches were detected. Consequence: Middle-click emulation (bound to three-finger tap) would behave unreliably. Fix: The synaptics driver's tap detection heuristic is modified to sense triple tap more reliably. Result: Middle-click emulation works as expected.
Clone Of:
Environment:
Last Closed: 2015-03-05 08:30:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0374 normal SHIPPED_LIVE xorg-x11, libdrm, and mesa bug fix and enhancement update 2015-03-05 12:52:35 UTC

Description Tomas Pelka 2014-07-25 09:14:06 UTC
Description of problem:
I think middle-click by gesture (three fingers click) is not supported in rhel7 on T440. It is working on rhel6 as a charm.

Version-Release number of selected component (if applicable):
xorg-x11-drv-synaptics-1.7.1-10.el7_0.1.x86_64
xorg-x11-server-Xorg-1.15.0-7.el7.x86_64
kernel-3.10.0-123.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1. do three-finger click on link in Firefox
2.
3.

Actual results:
link should be opened in new tab

Expected results:
right-click generated instead of middle-click

Additional info:

Comment 1 Tomas Pelka 2014-07-25 09:15:19 UTC
OK got the middle-click but it is not that easy to generate as in rhel6.

Comment 4 Peter Hutterer 2014-08-14 05:14:53 UTC
MODIFIED

xorg-x11-drv-synaptics-1.7.1-12.el7 is available in brew

Comment 8 errata-xmlrpc 2015-03-05 08:30:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0374.html


Note You need to log in before you can comment on or make changes to this bug.