Bug 11233 - lpd spontaneously dies
Summary: lpd spontaneously dies
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lpr   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
: 11232 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-05 00:31 UTC by hellyj
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-05 14:01:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hellyj 2000-05-05 00:31:35 UTC
- HP Laserjet 6MP as /dev/lp0 and filter HP Laserjet.
- /usr/sbin/lpc shows no daemon present but all else operational
- /usr/sbin/lpd will cause enqueued jobs to print normally
- re-check with /usr/sbin/lpc shows no daemon present

- tried deleting /etc/printcap and redefining after re-boot with same
result

- also in /var/log/messages is the following after restarting lpd:

May  4 16:42:26 hellyj-3 PAM_pwdb[932]: (su) session closed for user root
May  4 17:17:19 hellyj-3 lpd[1130]: restarted
May  4 17:17:19 hellyj-3 lpd[1130]: printer/tcp: unknown service
May  4 17:19:01 hellyj-3 lpd[1135]: restarted
May  4 17:19:01 hellyj-3 lpd[1135]: printer/tcp: unknown service

suggesting that printer/tcp service is being sought, not found, and causing
the daemon to stop.

Comment 1 Bernhard Rosenkraenzer 2000-05-05 13:59:59 UTC
*** Bug 11232 has been marked as a duplicate of this bug. ***

Comment 2 Bernhard Rosenkraenzer 2000-05-05 14:01:59 UTC
printer should be defined as port 515 in /etc/services...

Make sure your /etc/services file contains the line

printer	515/tcp	spooler


Note You need to log in before you can comment on or make changes to this bug.