Bug 112330 - grub behaves badly in the absence of a splashimage
grub behaves badly in the absence of a splashimage
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: grub (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
: 143701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-17 16:06 EST by Bill Nottingham
Modified: 2014-03-16 22:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 10:52:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2003-12-17 16:06:52 EST
If you remove redhat-logos, grub's splashimage isn't there. This leads to:

a) no menu being displayed
b) corruption of the video font

Either grub should require redhat-logos (ick) or handle this case better.
Comment 1 nathan r. hruby 2004-06-14 12:57:23 EDT
Ping.  If you install via serial console, anaconda is smart enough to
not put the spalshimage line in the grub.conf it creates for you. 
Clearly someone else knows about this too :)
Comment 2 Bill Nottingham 2005-01-04 14:23:03 EST
*** Bug 143701 has been marked as a duplicate of this bug. ***
Comment 3 Peter Jones 2005-01-05 11:13:44 EST
*** Bug 143701 has been marked as a duplicate of this bug. ***
Comment 4 Peter Jones 2005-01-11 10:52:45 EST
Fixed in rawhide.
Comment 5 Nigel Horne 2005-01-12 04:02:44 EST
What is rawhide? 
 
I've done a "yum update" and no new grub has come through. 

Note You need to log in before you can comment on or make changes to this bug.