Bug 1123514 - subscription-manager register failed
Summary: subscription-manager register failed
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Subscription Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Eric Helms
QA Contact: sthirugn@redhat.com
URL:
Whiteboard:
: 1124470 (view as bug list)
Depends On:
Blocks: 1112802
TreeView+ depends on / blocked
 
Reported: 2014-07-25 21:48 UTC by sthirugn@redhat.com
Modified: 2014-09-11 12:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:27:46 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1112802 None CLOSED Subscription manager routes should be anchored at their own API. 2019-06-26 21:02:07 UTC

Internal Links: 1112802

Description sthirugn@redhat.com 2014-07-25 21:48:11 UTC
Description of problem:
subscription-manager register failed

Version-Release number of selected component (if applicable):
Build: Satellite-6.0.4-RHEL-6-20140723.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.29-1.el6sat.noarch
* foreman-compute-1.6.0.29-1.el6sat.noarch
* foreman-gce-1.6.0.29-1.el6sat.noarch
* foreman-libvirt-1.6.0.29-1.el6sat.noarch
* foreman-ovirt-1.6.0.29-1.el6sat.noarch
* foreman-postgresql-1.6.0.29-1.el6sat.noarch
* foreman-proxy-1.6.0.21-1.el6sat.noarch
* foreman-selinux-1.6.0-8.el6sat.noarch
* foreman-vmware-1.6.0.29-1.el6sat.noarch
* katello-1.5.0-27.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.56-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch


How reproducible:
Always

Steps to Reproduce:
1. Subscription-manager register fails for all scenarios:
 
Using activation-key:
# subscription-manager register --org=rhcorp --activationkey=ak1
'exceptions.ValueError' object has no attribute 'msg'

Without activation-key:
# subscription-manager register --org=rhcorp --environment='DEV/cv1' --force
Username: admin
Password: 
'exceptions.ValueError' object has no attribute 'msg'

Actual results:
==> /var/log/foreman/production.log <==
Processing by Katello::Api::V2::RootController#resource_list as JSON
  Parameters: {"api_version"=>"v2", "root"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/root/resource_list.json.rabl within katello/api/v2/layouts/collection (2.7ms)
Completed 200 OK in 17ms (Views: 3.4ms | ActiveRecord: 0.0ms)
Processing by Katello::Api::V2::PingController#server_status as JSON
  Parameters: {"api_version"=>"v2", "ping"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/ping/server_status.json.rabl within katello/api/v2/layouts/resource (0.9ms)
Completed 200 OK in 3ms (Views: 1.9ms | ActiveRecord: 0.0ms)

ActionController::RoutingError (No route matches [POST] "/katello/api/consumers"):
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'


Expected results:


Additional info:
* This box had lot of automation so not attaching foreman-debug.  But this is very easily reproducible as I mentioned above.

Comment 2 RHEL Product and Program Management 2014-07-25 22:13:51 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 4 sthirugn@redhat.com 2014-07-28 14:09:39 UTC
The following workaround fixed the issue.  Looks like this issue is caused by the fix for an other bug: https://bugzilla.redhat.com/show_bug.cgi?id=1112802

Changing /etc/rhms/rhsm.conf:
from:
# Server prefix:
prefix = /katello/api

to 

# Server prefix:
prefix = /rhsm

Comment 5 Jan Hutař 2014-07-29 14:56:21 UTC
*** Bug 1124470 has been marked as a duplicate of this bug. ***

Comment 6 Og Maciel 2014-08-01 14:16:10 UTC
This is still present on build Satellite/Satellite-6.0.4-RHEL-6-20140730.0

Comment 7 Eric Helms 2014-08-01 14:20:51 UTC
The installer needs this - https://github.com/Katello/katello-installer/pull/85

Comment 9 sthirugn@redhat.com 2014-08-07 13:49:51 UTC
Verified.

Version Tested:
GA Snap 4 - Satellite-6.0.4-RHEL-6-20140806.0

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.38-1.el6sat.noarch
* foreman-compute-1.6.0.38-1.el6sat.noarch
* foreman-gce-1.6.0.38-1.el6sat.noarch
* foreman-libvirt-1.6.0.38-1.el6sat.noarch
* foreman-ovirt-1.6.0.38-1.el6sat.noarch
* foreman-postgresql-1.6.0.38-1.el6sat.noarch
* foreman-proxy-1.6.0.23-1.el6sat.noarch
* foreman-selinux-1.6.0.4-1.el6sat.noarch
* foreman-vmware-1.6.0.38-1.el6sat.noarch
* katello-1.5.0-28.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.6-1.el6sat.noarch
* katello-installer-0.0.57-1.el6sat.noarch
* openldap-2.4.23-34.el6_5.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.30.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.30.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.30.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.30.beta.el6sat.noarch
* pulp-server-2.4.0-0.30.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch
* sssd-ldap-1.11.5.1-3.el6.x86_64

Comment 11 Bryan Kearney 2014-09-11 12:27:46 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.