Bug 1123670 - RFE: error message when installing obsoleted packages
Summary: RFE: error message when installing obsoleted packages
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-27 21:40 UTC by Jaroslav Škarvada
Modified: 2014-07-28 04:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 04:57:34 UTC


Attachments (Terms of Use)

Description Jaroslav Škarvada 2014-07-27 21:40:11 UTC
Description of problem:
Dnf doesn't show error message (like yum does) when trying to install obsoleted packages which may lead to confusing errors.

Version-Release number of selected component (if applicable):
dnf-0.5.4-1.fc20

How reproducible:
Always

Steps to Reproduce:
1. dnf install blueman

Actual results:
Error: nothing provides gvfs-obexftp needed by blueman-1.23-7.fc20.x86_64

Expected results:
Package blueman-1.23-7.fc20.x86_64 is obsoleted by bluez-5.18-1.fc20.x86_64 which is already installed

Additional info:
Yum shows the above message (from expected results) which is probably better as it directly points user where the problem is.

Comment 1 Ales Kozumplik 2014-07-28 04:57:34 UTC
Hello Jaroslav,

This is not a bug, blueman can not be installed anyway and DNF first runs into the requires error before checking the obsoletes.


Note You need to log in before you can comment on or make changes to this bug.