Bug 1123730 - httpd logrotate specifies ineffective "delaycompress"
Summary: httpd logrotate specifies ineffective "delaycompress"
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: httpd
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Kaluža
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 06:56 UTC by A. Galama
Modified: 2014-08-20 05:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-20 05:49:29 UTC


Attachments (Terms of Use)

Description A. Galama 2014-07-28 06:56:35 UTC
Description of problem:
logrotate config specifies "delaycompress" but lacks "compress".

Version-Release number of selected component (if applicable):
httpd-2.4.10-1.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
1. cat /etc/logrotate.d/httpd
2.
3.

Actual results:
logrotate config specifies "delaycompress" but lacks "compress". "delaycompress" only has effect when used in combination with "compress".

Expected results:
Depending on what the author intended, either add "compress" or remove "delaycompress".


Additional info:
$ cat /etc/logrotate.d/httpd 
/var/log/httpd/*log {
    missingok
    notifempty
    sharedscripts
    delaycompress
    postrotate
        /bin/systemctl reload httpd.service > /dev/null 2>/dev/null || true
    endscript
}

Comment 1 Jan Kaluža 2014-08-20 05:49:29 UTC
I think this is intentional. The "compress" directive can be specified globally in /etc/logrotate.conf (it's commented out by a default, but user can uncomment it). In this case you have no clue that httpd should use "delaycompress". "delaycompress" without "compress" does not break anything.


Note You need to log in before you can comment on or make changes to this bug.