Bug 1123775 - [abrt] system-config-printer: newprinter.py:3827:getNPPPD:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)
Summary: [abrt] system-config-printer: newprinter.py:3827:getNPPPD:UnicodeDecodeError:...
Keywords:
Status: CLOSED DUPLICATE of bug 1091945
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:52c0c9bf91e08a68c8c9d45e6be...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 08:52 UTC by Miro Hrončok
Modified: 2014-07-28 09:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-28 09:52:06 UTC


Attachments (Terms of Use)
File: backtrace (753 bytes, text/plain)
2014-07-28 08:52 UTC, Miro Hrončok
no flags Details
File: environ (2.08 KB, text/plain)
2014-07-28 08:52 UTC, Miro Hrončok
no flags Details

Description Miro Hrončok 2014-07-28 08:52:36 UTC
Description of problem:
Added a network printer and added a PPD by hand. http://www.openprinting.org/printer/HP/HP-LaserJet_6L

Selected the file, clicked Next

Version-Release number of selected component:
system-config-printer-1.4.5-1.fc20

Additional info:
reporter:       libreport-2.2.2
cmdline:        /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
dso_list:       system-config-printer-libs-1.4.5-1.fc20.noarch
executable:     /usr/share/system-config-printer/system-config-printer.py
kernel:         3.15.4-200.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
newprinter.py:3827:getNPPPD:UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/share/system-config-printer/newprinter.py", line 913, in on_btnNPForward_clicked
    self.nextNPTab()
  File "/usr/share/system-config-printer/newprinter.py", line 1466, in nextNPTab
    self.ppd = self.getNPPPD()
  File "/usr/share/system-config-printer/newprinter.py", line 3827, in getNPPPD
    ppd = cups.PPD(self.filechooserPPD.get_filename())
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc5 in position 20: ordinal not in range(128)

Local variables in innermost frame:
self: <NewPrinterGUI object at 0x13270f0 (newprinter+NewPrinterGUI at 0x141a2e0)>
ppd: None

Comment 1 Miro Hrončok 2014-07-28 08:52:40 UTC
Created attachment 921728 [details]
File: backtrace

Comment 2 Miro Hrončok 2014-07-28 08:52:41 UTC
Created attachment 921729 [details]
File: environ

Comment 3 Miro Hrončok 2014-07-28 08:56:59 UTC
The file was selected from ~/Stažené/ folder.

Placing the file somewhere else workarounds the problem.

I guess you need assume UTF-8 paths, not just ASCII.

Comment 4 Jiri Popelka 2014-07-28 09:52:06 UTC

*** This bug has been marked as a duplicate of bug 1091945 ***


Note You need to log in before you can comment on or make changes to this bug.