Bug 1123786 - Fail to create redmine quickstart with ruby-2.0
Summary: Fail to create redmine quickstart with ruby-2.0
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Templates
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Balazs Varga
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 09:15 UTC by weiwei jiang
Modified: 2016-10-30 22:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-05 13:18:46 UTC


Attachments (Terms of Use)

Description weiwei jiang 2014-07-28 09:15:10 UTC
Description of problem:
When I create redmine quickstart with ruby-2.0, it failed and display:
Stopping Ruby cartridge
Stopping MySQL 5.5 cartridge
Repairing links for 1 deployments
Building git ref 'master', commit e6670d3
cp: cannot stat `Gemfile.lock.ruby-2.0': No such file or directory
cp: cannot stat `config/database.yml-2.0': No such file or directory
Building Ruby cartridge
bundle install --deployment --path ./app-root/repo/vendor/bundle
NOTE: You can prevent installing certain Gemfile group using: rhc env set BUNDLE_WITHOUT=groupname
The --deployment flag requires a Gemfile.lock. Please make sure you have checked
your Gemfile.lock into version control before deploying.
An error occurred executing 'gear postreceive' (exit code: 16)
Error message: CLIENT_ERROR: Failed to execute: 'control build' for /var/lib/openshift/53d634e43e00d2ce90000ec6/ruby

and after I add the "Gemfile.lock.ruby-2.0" to the repo, the error message change to :
Stopping Ruby cartridge
Stopping MySQL 5.5 cartridge
Repairing links for 1 deployments
Building git ref 'master', commit e6670d3
Building Ruby cartridge
bundle install --deployment --path ./app-root/repo/vendor/bundle
NOTE: You can prevent installing certain Gemfile group using: rhc env set BUNDLE_WITHOUT=groupname
Fetching gem metadata from https://rubygems.org/.........
Fetching gem metadata from https://rubygems.org/..
Installing rake (10.1.1)
......
Installing yard (0.8.7.3)
Your bundle is complete!
It was installed into ./vendor/bundle
Post-install message from rdoc:
Depending on your version of ruby, you may need to install ruby rdoc/ri data:

<= 1.8.6 : unsupported
 = 1.8.7 : gem install rdoc-data; rdoc-data --install
 = 1.9.1 : gem install rdoc-data; rdoc-data --install
>= 1.9.2 : nothing to do! Yay!
Preparing build for deployment

Version-Release number of selected component (if applicable):
devenv_5011
rhc-1.28.3

How reproducible:
always

Steps to Reproduce:
1.Create a redmine quickstart with ruby-2.0 
rhc app create redmine ruby-2.0 mysql-5.5 --from-code=https://github.com/openshift/openshift-redmine-quickstart.git
2.
3.

Actual results:
Application Options
-------------------
Domain:      wjiang
Cartridges:  ruby-2.0, mysql-5.5
Source Code: https://github.com/openshift/openshift-redmine-quickstart.git
Gear Size:   default
Scaling:     no

Creating application 'redmine2' ...
The initial build for the application failed: Shell command '/sbin/runuser -s /bin/sh 53d634e43e00d2ce90000ec6 -c "exec
/usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c1007' /bin/sh -c \"gear postreceive --init >>
/tmp/initial-build.log 2>&1\""' returned an error. rc=255

.Last 10 kB of build output:
Stopping Ruby cartridge
Stopping MySQL 5.5 cartridge
Repairing links for 1 deployments
Building git ref 'master', commit e6670d3
cp: cannot stat `Gemfile.lock.ruby-2.0': No such file or directory
cp: cannot stat `config/database.yml-2.0': No such file or directory
Building Ruby cartridge
bundle install --deployment --path ./app-root/repo/vendor/bundle
NOTE: You can prevent installing certain Gemfile group using: rhc env set BUNDLE_WITHOUT=groupname
The --deployment flag requires a Gemfile.lock. Please make sure you have checked
your Gemfile.lock into version control before deploying.
An error occurred executing 'gear postreceive' (exit code: 16)
Error message: CLIENT_ERROR: Failed to execute: 'control build' for /var/lib/openshift/53d634e43e00d2ce90000ec6/ruby

For more details about the problem, try running the command again with the '--trace' option.


Expected results:
The app should be created successfully.

Additional info:

Comment 1 Balazs Varga 2014-08-05 13:18:46 UTC
Rails 3 applications probably won't work on our Ruby 2.0 cartridge because of Rack incompatibility[1]. We are using Rack 1.5.x with Passenger but Rails 3 requires Rack 1.4.x.

We have to wait until Redmine releases a version based on Rails 4.

I made a PR which updates the README of the project:
https://github.com/openshift/openshift-redmine-quickstart/pull/7

https://github.com/rails/rails/issues/10877


Note You need to log in before you can comment on or make changes to this bug.