Bug 1123823 - Add link to create a bug for the same product/component
Summary: Add link to create a bug for the same product/component
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs
Version: 4.4
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: 5.0-RH4
Assignee: Jeff Fearn 🐞
QA Contact: Rony Gong 🔥
URL:
Whiteboard:
: 1690705 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 11:11 UTC by Honza Horak
Modified: 2019-05-03 00:25 UTC (History)
1 user (show)

Fixed In Version: 5.0.4-rh18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-03 00:25:38 UTC


Attachments (Terms of Use)

Description Honza Horak 2014-07-28 11:11:10 UTC
Description of problem:
When reading some BZ report and finding out that this is not a bug I'm seeing, I need to submit a new bug report.

In that moment I'd like to have a link similar to "clone this bug", which would only send me to "Enter new bug" page, but would not pre-fill summary/text and other fields; however, it would fill-in product/version/component. This could be called "Submit similar bug" and be placed near "Clone this bug" link.

Comment 1 Jason McDonald 2014-09-01 08:12:54 UTC
Ideally this can be implemented in the upstream Bugzilla so that Red Hat doesn't have to carry the extra custom code.

Comment 2 Jeff Fearn 🐞 2019-01-30 06:13:20 UTC
We should just have links next to product/component/subcomponent that link to the new bug page with those details loaded.

Comment 3 Rony Gong 🔥 2019-03-18 09:48:31 UTC
Failed on the QA server.

All work well except clicking the create bug link beside subcomponent, it will not set current bug's subcomponent as default, it used the null.

Comment 4 Jeff Fearn 🐞 2019-03-18 11:58:49 UTC
(In reply to Rony Gong from comment #3)
> Failed on the QA server.
> 
> All work well except clicking the create bug link beside subcomponent, it
> will not set current bug's subcomponent as default, it used the null.

AFAICT you can't create a link to set the sub_component this way, is that expected? If so do you have an example link of it working?

Comment 5 Rony Gong 🔥 2019-03-18 13:01:26 UTC
(In reply to Jeff Fearn from comment #4)
> (In reply to Rony Gong from comment #3)
> > Failed on the QA server.
> > 
> > All work well except clicking the create bug link beside subcomponent, it
> > will not set current bug's subcomponent as default, it used the null.
> 
> AFAICT you can't create a link to set the sub_component this way, is that
> expected? If so do you have an example link of it working?

This was introduced by you in comment 2. You said it should work for subcomponent too.

Comment 6 Jeff Fearn 🐞 2019-03-18 21:21:23 UTC
(In reply to Rony Gong from comment #5)
> (In reply to Jeff Fearn from comment #4)
> > (In reply to Rony Gong from comment #3)
> > > Failed on the QA server.
> > > 
> > > All work well except clicking the create bug link beside subcomponent, it
> > > will not set current bug's subcomponent as default, it used the null.
> > 
> > AFAICT you can't create a link to set the sub_component this way, is that
> > expected? If so do you have an example link of it working?
> 
> This was introduced by you in comment 2. You said it should work for
> subcomponent too.

This doesn't answer my question. If there are no such links that work, then I'm going to remove the link. But if you have an example of such a link working then I'll try and work out why this one doesn't.

Comment 7 Rony Gong 🔥 2019-03-19 02:27:22 UTC
ok, then my recommendation is removing that link besides the subcomponent. Then we support 
1. create a bug with current product as the default value, no component selected
2. create a bug with current product and component as the default.

Comment 8 Rony Gong 🔥 2019-03-20 03:42:56 UTC
Verified on QA server, PASS

Comment 9 Jeff Fearn 🐞 2019-03-20 12:54:44 UTC
*** Bug 1690705 has been marked as a duplicate of this bug. ***

Comment 10 Rony Gong 🔥 2019-03-21 02:46:17 UTC
Verified on QA server, PASS

Comment 12 Jeff Fearn 🐞 2019-04-16 00:32:20 UTC
This change has been deployed to partner bugzilla, please test and let us know if you have any issues.

https://partner-bugzilla.redhat.com/

Comment 13 Jeff Fearn 🐞 2019-05-03 00:25:38 UTC
This change is now live. If there are any issues, do not reopen this
bug. Instead, you should create a new bug and reference this bug.


Note You need to log in before you can comment on or make changes to this bug.