Bug 1123875 - [CISCO RHEL-OSP] No Options in PackStack answers file to specify http-proxy.
Summary: [CISCO RHEL-OSP] No Options in PackStack answers file to specify http-proxy.
Keywords:
Status: CLOSED DUPLICATE of bug 1134069
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z1
: 5.0 (RHEL 7)
Assignee: Martin Magr
QA Contact: Ami Jeain
URL:
Whiteboard:
Depends On:
Blocks: 1154145 1154162 1134069 1154159
TreeView+ depends on / blocked
 
Reported: 2014-07-28 14:00 UTC by Rahul Upadhyaya
Modified: 2014-10-17 21:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1134069 (view as bug list)
Environment:
Last Closed: 2014-08-26 18:36:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 115940 None None None Never

Description Rahul Upadhyaya 2014-07-28 14:00:34 UTC
Description of problem:
Specifying Proxy information via PackStack Answer file is not possible due to lack of parameter in the answer file to support this. This requires user to manually configure proxy on each node on which openstack components would be installed.

Version-Release number of selected component (if applicable):
OSP5 on RHEL7

How reproducible:
Run a Packstack based Openstack install behind a Web-proxy enabled environment.

Steps to Reproduce:
1. Run a Packstack based Openstack install behind a Web-proxy enabled environment.
2.
3.

Actual results:
Installation would fail on Nodes to be provisioned due to lack of proxy params unless manually specified.

Expected results:
there should be a way to specify and configure proxy information on the Openstack nodes to be provisioned by Packstack.

Additional info:

Comment 2 Martin Magr 2014-07-31 08:03:30 UTC
Please specify exactly what is required to add.

Comment 3 Rahul Upadhyaya 2014-08-13 13:10:22 UTC
Hey Martin,

If we could add params that could specify the proxy info required by subscription manager to work. Currently I have to configure the subscription manager proxy in each of the nodes I want to provision via packstack.

Comment 4 Rahul Upadhyaya 2014-08-13 13:14:54 UTC
To make it more clear, I want this - If I want to specify the proxy for subscription manager on the nodes on which i would  installing my openstack services, I want a way through the answers file to do so. Basically couple of params specifying proxy which subscription would use.

Comment 5 Joe Donohue 2014-08-26 18:36:36 UTC

*** This bug has been marked as a duplicate of bug 1134069 ***


Note You need to log in before you can comment on or make changes to this bug.