Bug 1124012 - Certificate error during install from ISO
Summary: Certificate error during install from ISO
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer
Version: 6.0.0
Hardware: All
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-28 19:48 UTC by Brett Thurber
Modified: 2014-07-31 13:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-31 13:57:25 UTC


Attachments (Terms of Use)

Description Brett Thurber 2014-07-28 19:48:55 UTC
Description of problem:
When installing Sat 6 beta from ISO, an error occurs during install when specifying the certificate location.
Where is your satellite certificate file? /root/9c696689-5213-48e2-9431-841142faa2a9.pem
** Loading Red Hat Satellite Certificate.
** Verifying certificate locally.
Error parsing satellite cert: :1: parser error : Start tag expected, '<' not found[root@sysman-sat6 iso]# 

Version-Release number of selected component (if applicable):
Sat 6 beta

How reproducible:
Every time

Steps to Reproduce:
1. Execute install.pl from the Sat 6 ISO
2. Partially through the install you are prompted for the satellite certificate
3. Provide the path to the identify cert downloaded from the customer portal
4. Error received

Actual results:
Where is your satellite certificate file? /root/9c696689-5213-48e2-9431-841142faa2a9.pem
** Loading Red Hat Satellite Certificate.
** Verifying certificate locally.
Error parsing satellite cert: :1: parser error : Start tag expected, '<' not found[root@sysman-sat6 iso]# 

Expected results:
Installation proceeds.

Additional info:
N/A

Comment 1 RHEL Product and Program Management 2014-07-28 20:04:50 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Mike McCune 2014-07-31 13:56:43 UTC
install.pl is from a Satellite 5 ISO, Satellite 6 ISO has an install script called "install_packages":


# mount -o loop Satellite-6.0.4-RHEL-6-20140730.0-Satellite-x86_64-dvd1.iso /var/tmp/iso/

# ls /var/tmp/iso
install_packages  Packages  README  repodata  TRANS.TBL

looks like you grabbed a Sat5 ISO instead of Sat6

Comment 4 Mike McCune 2014-07-31 13:57:25 UTC
Going to close this one and feel free to re-open if you are seeing 'install.pl' inside a Sat6 ISO


Note You need to log in before you can comment on or make changes to this bug.