Bug 112408 - xemacs segfault when running gdm session from cygwin xserver
xemacs segfault when running gdm session from cygwin xserver
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
1
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-18 23:16 EST by Brian Bielinski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-22 04:01:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Bielinski 2003-12-18 23:16:51 EST
Description of problem:
running xserver on a windows2000 XFree86-xserv-4.3.0-25.
using gdm login.(works fine)
attempt to run xemacs (from the command line) produces a segfault.
running xemacs on the local (fedora box) works fine.
this has not happened to me on any previous rh release.

Version-Release number of selected component (if applicable):
xemacs-21.4.14-3

How reproducible:
everytime

Steps to Reproduce:
1.start cygwin xserver on win2000 box
2.after loggin in, from command line on fedora type "xemacs"
3.watch the segfault below.
  
Actual results:
[brian@drcpdc brian]$ xemacs
Warning: Missing charsets in String to FontSet conversion
Warning: Cannot convert string
"-*-helvetica-bold-r-*-*-*-120-*-*-*-*-iso8859-*,                    
   -*-*-*-*-*-*-*-120-*-iso10646-1,                      
-*-*-*-*-*-*-*-120-*-jisx0208.1983-0,                   
-*-*-*-*-*-*-*-120-*-jisx0201.1976-0,                  
-*-*-*-*-*-*-*-120-*-*-*" to type FontSet
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
 
Fatal error (11).
 
Your files have been auto-saved.
Use `M-x recover-session' to recover them.
 
Your version of XEmacs was distributed with a PROBLEMS file that  may
describe
your crash, and with luck a workaround.  Please check it first, but do
report
the crash anyway.  Please report this bug by invoking M-x
report-emacs-bug,
or by selecting `Send Bug Report' from the Help menu.  If necessary, send
ordinary email to `crashes@xemacs.org'.  *MAKE SURE* to include the XEmacs
configuration from M-x describe-installation, or equivalently the file
Installation in the top of the build tree.
 
*Please* try *hard* to obtain a C stack backtrace; without it, we are
unlikely
to be able to analyze the problem.  Locate the core file produced as a
result
of this crash (often called `core' or `core.<process-id>', and located in
the directory in which you started XEmacs or your home directory), and
type
 
  gdb /usr/bin/xemacs core
 
then type `where' at the debugger prompt.  No GDB on your system?  You may
have DBX, or XDB, or SDB.  (Ask your system administrator if you need
help.)
If no core file was produced, enable them (often with `ulimit -c
unlimited'
in case of future recurrance of the crash.
 
Lisp backtrace follows:
 
  # bind (frame-being-created)
  make-frame(nil #<x-device on "10.2.2.2:2.0" 0xa95>)
  frame-initialize()
  # bind (debugger debug-on-error command-line-args-left)
  command-line()
  # (condition-case ... . ((t (byte-code "      ��" ... 1))))
  # bind (error-data)
  normal-top-level()
  # (condition-case ... . error)
  # (catch top-level ...)
Segmentation fault
[brian@drcpdc brian]$


Expected results:
one solution is:

[brian@drcpdc brian]$ export LANG=en
[brian@drcpdc brian]$ xemacs
[brian@drcpdc brian]$

Additional info:
this seems to be a problem with the font server interaction.  as i
said above, this problem hasn't existed (for me) for any of the
previous redhat releases.

thanks!
Comment 1 Jens Petersen 2003-12-22 04:01:20 EST
I suggest you report this to the XEmacs developers on an
xemacs mailing-list directly.  Cygwin is an unsupported
environment as far as Fedora Core or RHL is concerned.

Note You need to log in before you can comment on or make changes to this bug.