Bug 112416 - buildinstall queries redhat-release rpm
buildinstall queries redhat-release rpm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-19 08:34 EST by Chris Rouch
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-19 15:07:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Rouch 2003-12-19 08:34:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.10 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
If version isn't specified on the command line the script tries to
query redhat-release rather than fedora-release  (line 66)

Version-Release number of selected component (if applicable):
anaconda-runtime-9.2-2

How reproducible:
Always

Steps to Reproduce:
1./usr/lib/anaconda-runtime/buildinstall --prodpath RedHat --product
fc1 --pkgorder /a/yarrow/cdrom/pkgorder.txt --release 1 /a/yarrow/cdrom
2.
3.
    

Actual Results:  recursion fails because version isn't set

Expected Results:  recursion should succeed without errors

Additional info:

if --version is specified this is not a problem
Comment 1 Jeremy Katz 2003-12-19 15:07:31 EST
I highly recommend passing --version.  In fact, enough so that I just
changed cvs to require it :-)

Note You need to log in before you can comment on or make changes to this bug.