Bug 112417 - Executed rpm -Uhv setools-1.0.1-3.i386.rpm, printed error message
Executed rpm -Uhv setools-1.0.1-3.i386.rpm, printed error message
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: setools (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-19 08:51 EST by sangu
Modified: 2007-04-18 13:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.1-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-04 21:27:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2003-12-19 08:51:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ko-KR; rv:1.5)
Gecko/20031016 Epiphany/1.0.6

Description of problem:
mkdir -p tmp
( cd domains/program/ ; for n in *.te ; do echo "define(\`$n')"; done
) > tmp/program_used_flags.te
( cd domains/misc/ ; for n in *.te ; do echo "define(\`$n')"; done )
>> tmp/program_used_flags.te
cat domains/*.te domains/misc/*.te domains/program/*.te >
tmp/all_domains.te
cat attrib.te tmp/program_used_flags.te tmp/all_macros.te
tmp/all_types.te tmp/all_domains.te assert.te > tmp/all.te
m4  -Imacros -s tmp/all.te rbac > tmp/te-rbac.m4
m4  -Imacros -s tmp/program_used_flags.te tmp/all_macros.te
constraints initial_sid_contexts fs_use genfs_contexts net_contexts >
tmp/constraints-contexts.m4
mkdir -p tmp
cat flask/security_classes flask/initial_sids flask/access_vectors
tmp/te-rbac.m4 users tmp/constraints-contexts.m4 > policy.conf
mkdir -p /etc/security/selinux/src
install -m 644 policy.conf /etc/security/selinux/src/policy.conf
mkdir -p /etc/security/selinux
/usr/bin/checkpolicy -o /etc/security/selinux/policy.15
/etc/security/selinux/src/policy.conf
/usr/bin/checkpolicy:  loading policy configuration from
/etc/security/selinux/src/policy.conf
ERROR 'unknown type pam_var_run_t' at token ';' on line 27619:
allow sudo_t pam_var_run_t:dir { create read getattr lock setattr
ioctl link unlink rename search add_name remove_name reparent write
rmdir };
allow sudo_t var_run_t:dir { read getattr lock search ioctl };
/usr/bin/checkpolicy:  error(s) encountered while parsing configuration
make: *** [/etc/security/selinux/policy.15] Error 1
mkdir -p /etc/security/selinux
/usr/bin/checkpolicy -o /etc/security/selinux/policy.15
/etc/security/selinux/src/policy.conf
/usr/bin/checkpolicy:  loading policy configuration from
/etc/security/selinux/src/policy.conf
ERROR 'unknown type pam_var_run_t' at token ';' on line 27619:
allow sudo_t pam_var_run_t:dir { create read getattr lock setattr
ioctl link unlink rename search add_name remove_name reparent write
rmdir };
allow sudo_t var_run_t:dir { read getattr lock search ioctl };
/usr/bin/checkpolicy:  error(s) encountered while parsing configuration
make: *** [/etc/security/selinux/policy.15] Error 1
chcon: failed to change context of /usr/bin/seuser to
system_u:object_r:seuser_exec_t: Invalid argument
chcon: failed to change context of /usr/lib/apol/seuser.conf to
system_u:object_r:seuser_conf_t: Invalid argument
error: %post(setools-1.0.1-3) scriptlet failed, exit status 1


Version-Release number of selected component (if applicable):
setools-1.0.1-3.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uhv setools-1.0.1-3.rpm
2. printed error message
3.
    

Additional info:
Comment 1 Daniel Walsh 2003-12-29 06:43:36 EST
Fixed in latest policy files.

Dan
Comment 2 sangu 2003-12-29 23:05:18 EST
#rpm -Uhv setools-1.1-1.i386.rpm
Preparing...               
########################################### [100%]
   1:setools               
########################################### [100%]
mkdir -p tmp
( cd domains/program/ ; for n in *.te ; do echo "define(\`$n')"; done
) > tmp/program_used_flags.te
( cd domains/misc/ ; for n in *.te ; do echo "define(\`$n')"; done )
>> tmp/program_used_flags.te
cat domains/*.te domains/misc/*.te domains/program/*.te >
tmp/all_domains.te
cat attrib.te tmp/program_used_flags.te tmp/all_macros.te
tmp/all_types.te tmp/all_domains.te assert.te > tmp/all.te
m4  -Imacros -s tmp/all.te rbac > tmp/te-rbac.m4
m4  -Imacros -s tmp/program_used_flags.te tmp/all_macros.te
constraints initial_sid_contexts fs_use genfs_contexts net_contexts >
tmp/constraints-contexts.m4
mkdir -p tmp
cat flask/security_classes flask/initial_sids flask/access_vectors
tmp/te-rbac.m4 users tmp/constraints-contexts.m4 > policy.conf
mkdir -p /etc/security/selinux/src
install -m 644 policy.conf /etc/security/selinux/src/policy.conf
mkdir -p /etc/security/selinux
/usr/bin/checkpolicy -o /etc/security/selinux/policy.15
/etc/security/selinux/src/policy.conf
/usr/bin/checkpolicy:  loading policy configuration from
/etc/security/selinux/src/policy.conf
security:  3 users, 5 roles, 296 types
security:  30 classes, 13925 rules
/usr/bin/checkpolicy:  policy configuration loaded
/usr/bin/checkpolicy:  writing binary representation (version 15) to
/etc/security/selinux/policy.15
/usr/sbin/load_policy /etc/security/selinux/policy.15
touch tmp/load
chcon: /usr/lib/apol/seuser.conf: No such file or directory
error: %post(setools-1.1-1) scriptlet failed, exit status 1

"/usr/lib/apol/seuser.conf" file is in setools-gui-1.1-1.i386.rpm
I can't be preinstalled setools-gui because setools-gui package
depends on setools.

Installed policy-1.4.3 and policy-sources 1.4.3.
Comment 3 sangu 2003-12-29 23:16:35 EST
#rpm -Uhv setools-devel-1.1-1.i386.rpm
Preparing...               
########################################### [100%]
   1:setools-devel          warning: user bhcompile does not exist -
using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
warning: user bhcompile does not exist - using root
warning: group bhcompile does not exist - using root
########################################### [100%]
Comment 4 sangu 2004-01-04 21:27:57 EST
Installing etools-1.1-2, setools-gui-1.1-2 and setools-devel-1.1-2 are
no error messages.

Note You need to log in before you can comment on or make changes to this bug.