Bug 1124343 - Got "The server does not support adding or removing members on this resource." when run 'domain show/list' against OSE-1.2 env
Summary: Got "The server does not support adding or removing members on this resource....
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: oc
Version: 2.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Fabiano Franz
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 09:38 UTC by XiuJuan Wang
Modified: 2015-05-15 02:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-10 00:49:58 UTC


Attachments (Terms of Use)

Description XiuJuan Wang 2014-07-29 09:38:18 UTC
Description of problem:
Can't domain show and list,these two commands will check members, but ose-1.2 don't support member,so get error as following:
# rhc domain show   -d
DEBUG: Using config file /root/.openshift/express.conf
DEBUG: Git config 'git config --get rhc.app-id' returned ''
DEBUG: Git config 'git config --get rhc.app-name' returned ''
DEBUG: Git config 'git config --get rhc.domain-name' returned ''
DEBUG: Authenticating with RHC::Auth::Token
DEBUG: Connecting to https://10.3.8.106/broker/rest/api
DEBUG: Getting all domains
DEBUG: Client supports API versions 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7
DEBUG: Using token authentication
DEBUG: Created new httpclient
DEBUG: Request GET https://10.3.8.106/broker/rest/api
DEBUG: SSL Verification failed -- Using self signed cert
DEBUG:    code 200 1309 ms
DEBUG: Server supports API versions 1.0, 1.1, 1.2, 1.3, 1.4
DEBUG:    Using API version 1.4
DEBUG: Client API version 1.4 is not current. Refetching API
DEBUG: Using token authentication
DEBUG: Request GET https://10.3.8.106/broker/rest/api
DEBUG: SSL Verification failed -- Using self signed cert
DEBUG:    code 200 1071 ms
DEBUG: Using token authentication
DEBUG: Request GET https://10.3.8.106/broker/rest/domains
DEBUG: SSL Verification failed -- Using self signed cert
DEBUG:    code 200 1096 ms
DEBUG: Finding domain cat
DEBUG: Getting all domains
DEBUG: Getting all applications for domain 
DEBUG: Using token authentication
DEBUG: Request GET https://10.3.8.106/broker/rest/domains/cat/applications?include=cartridges
DEBUG: SSL Verification failed -- Using self signed cert
DEBUG:    code 200 1123 ms
DEBUG: Getting all members for 
The server does not support adding or removing members on this resource.

rhc-1.25.2 could domain show/list,no such error.

Version-Release number of selected component (if applicable):
rhc-1.28.4
ose-1.2

How reproducible:
always

Steps to Reproduce:
1.Domain show agaisnt ose-1.2 env
2.Domain list agaisnt ose-1.2 env
3.

Actual results:
# rhc domain show 
The server does not support adding or removing members on this resource.
# rhc domain list 
The server does not support adding or removing members on this resource.

Expected results:
Could domain show and list against ose-1.2 env.

Additional info:
Against ose-2.0 and ose-2.1, no such error, becasue ose-1.2 is not support member feature, while rhc-1.28.4 is accessing member rest api.

Comment 4 Fabiano Franz 2014-07-29 19:41:59 UTC
Fixed in https://github.com/openshift/rhc/pull/635

Comment 5 openshift-github-bot 2014-07-30 00:21:57 UTC
Commit pushed to master at https://github.com/openshift/rhc

https://github.com/openshift/rhc/commit/a197a8c9dcf69d04550017bfaddec32a228e625d
Bug 1124343 - show|list domain must tolerate servers with no membership support

Comment 6 XiuJuan Wang 2014-07-30 02:58:00 UTC
rhc build from devenv_5027

Can't reproduce this issue on ose-12 env.Move bug to verified.Thanks!

#rhc domain list 
Domain cat
----------
  Suffix: ose-12.com.cn

You have access to 1 domain.


Note You need to log in before you can comment on or make changes to this bug.