Bug 1124391 - BPM Suite on Tomcat7 returns http 409 error on complete task when using rest call
Summary: BPM Suite on Tomcat7 returns http 409 error on complete task when using rest ...
Keywords:
Status: CLOSED DUPLICATE of bug 1125107
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Documentation
Version: 6.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Vikram Goyal
QA Contact: Marek Baluch
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 12:05 UTC by Amana
Modified: 2018-12-06 17:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Build Name: 22689, Installation Guide-6.0-1 Build Date: 30-06-2014 16:10:03 Topic ID: 22560-642515 [Latest]
Last Closed: 2014-07-31 04:31:52 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1146573 None None None Never

Description Amana 2014-07-29 12:05:57 UTC
Title: Setting up transaction manager for Red Hat JBoss Web Server 2.0 (Tomcat 7)

Describe the issue:

The following error is experiencied when using rest call (i.e.:   http://localhost:8080/business-central/rest/task/99/complete) to complete a human task BRMS 6.0.2 running on Tomcat7:

    WARN  Exception thrown when processing request [/task/1/complete]; responding with status 409
    org.kie.remote.services.rest.exception.RestOperationException: User '[UserImpl:'user1']' was unable to execution operation 'Complete' on task id 1 due to a no 'current status' match...

The same test case works if BRMS 6 is running on EAP 6. The problem is gone if the following setting is used in setenv.sh:

  -Djbpm.tsr.jndi.lookup=java:comp/env/TransactionSynchronizationRegistry

This setting needs to be included in step 8 in documentation. It is already described in the existing README.txt file in business-central.war (jboss-bpms-6.0.2.GA-redhat-5-deployable-generic/jboss-bpms-manager/business-central.war/README.txt).

Suggestions for improvement:

Add setting in step 8: -Djbpm.tsr.jndi.lookup=java:comp/env/TransactionSynchronizationRegistry

Comment 6 Vikram Goyal 2014-07-31 04:29:43 UTC
@Marek - sure here it is [1].

I understand that Ivo added that note for the inclusion in the Installation Guide but I don't think it got picked up. If a product bug requires a change in documentation it is best to create a cloned bug with its component set to Documentation otherwise it is hard for us to track the work.

I have now created a separate bug for tracking this work [2].

[1] https://access.redhat.com/documentation/en-US/Red_Hat_JBoss_BPM_Suite/6.0/html-single/Installation_Guide/index.html#Setting_up_transaction_manager

[2] https://bugzilla.redhat.com/show_bug.cgi?id=1125107


Note You need to log in before you can comment on or make changes to this bug.