Bug 1124395 - Outdated instructions for javadocs download in API Documentation
Summary: Outdated instructions for javadocs download in API Documentation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: EAP 6.3.0
Assignee: eap-docs
QA Contact: Nikoleta Ziakova
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 12:10 UTC by Nikoleta Ziakova
Modified: 2014-08-07 06:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-07 06:19:25 UTC
Type: Bug


Attachments (Terms of Use)

Description Nikoleta Ziakova 2014-07-29 12:10:13 UTC
There is a note box in API documentation [1]:

You can download a ZIP archive including this same documentation from the Red Hat Customer Portal at http://access.redhat.com. Click the Support section, then choose JBoss Enterprise Application Platform. 

These instructions are outdated because Customer Portal has changed. Also now it is "Red Hat JBoss Enterprise Application Platform" instead of "JBoss Enterprise Application Platform".

[1] https://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/API_Documentation/index.html

Comment 1 Russell Dickenson 2014-07-30 01:09:52 UTC
Docs Notes
==========
The source of the JBoss EAP 6.3.0 "API Documentation" can be found at [1]. It is stored in a Subversion repository because it consists of hundreds of individual files, which is not suitable for storage in PressGang CCMS.

QE Notes
========
I have amended the instructions as requested. The difficulty at the moment is that although the menu mentions "Red Hat JBoss...." the destination remains using the product name "JBoss Enterprise Application Platform".

The amended text is available for verification in revision 6.3.0-1 (or higher) at [2].


[1] https://svn.devel.redhat.com/repos/ecs/JBoss_Enterprise_Application_Platform/releases/6.x/6.3.0/API_Documentation_6.3.0/
[2] https://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/API_Documentation/index.html

Comment 2 Nikoleta Ziakova 2014-07-30 07:25:13 UTC
The note box now contains these instructions:
You can download a ZIP archive including this same documentation from the Red Hat Customer Portal at http://access.redhat.com. Click the Support menu option, then click Red Hat JBoss Enterprise Application Platform in the Product Documentation submenu. 

However the ZIP archive is not part of Product Documentation but a part of EAP Software Downloads: for 6.3.0.Beta it is Red Hat JBoss Enterprise Application Platform 6.3.0 Beta Javadocs at [1]. For GA it will be probably something similar as for EAP 6.2.0.GA.

[1] https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?downloadType=distributions&product=appplatform&version=6.3.0+Beta

Comment 3 Russell Dickenson 2014-08-05 14:01:07 UTC
Docs Notes
==========
I have amended the instructions for downloading the API Documentation in Zip format, as per comment 2.

QE Notes
========
I have amended the instructions as per comment 2. Thank you for pointing out what should have been obvious. I was too focused on the menu structure and not on just where my instructions led the reader.

The amended text is now as follows, as can be confirmed at [1].

"You can download a ZIP archive including this same documentation from the Red Hat Customer Portal at http://access.redhat.com. From the Downloads menu, click Product Downloads. In the list of Product Downloads click Red Hat JBoss Enterprise Application Platform . From the Version menu select 6.3.0. Click Download beside Red Hat JBoss Enterprise Application Platform 6.3.0 Javadocs."


[1] https://documentation-devel.engineering.redhat.com/site/documentation/en-US/JBoss_Enterprise_Application_Platform/6.3/html-single/API_Documentation/index.html

Comment 4 Nikoleta Ziakova 2014-08-05 14:11:38 UTC
Verified, thanks for the fix!


Note You need to log in before you can comment on or make changes to this bug.