Bug 1124417 - perl-URI-Find-Simple-1.05-2.fc22 FTBFS: test fail with perl-URI-Find-20140709
Summary: perl-URI-Find-Simple-1.05-2.fc22 FTBFS: test fail with perl-URI-Find-20140709
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-URI-Find-Simple
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: http://koji.fedoraproject.org/koji/ta...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 12:52 UTC by Petr Pisar
Modified: 2014-08-04 13:29 UTC (History)
3 users (show)

Fixed In Version: perl-URI-Find-Simple-1.05-3.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 13:29:08 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
CPAN 97738 None None None Never

Description Petr Pisar 2014-07-29 12:52:48 UTC
perl-URI-Find-Simple-1.05-2.fc22 fails to build in F22 due to tests:

#   Failed test 'got news.com uri'
#   at t/find.t line 27.
#          got: 'http://www.news.com'
#     expected: 'http://www.news.com/'
#   Failed test 'got various.com uri'
#   at t/find.t line 28.
#          got: 'http://various.com'
#     expected: 'http://various.com/'
#   Failed test 'expcted matches new text'
#   at t/find.t line 43.
#          got: 'this is a long string with [[ http://www.news.com ]] urls in it in
# [[ http://various.com ]] different forms. [[ mailto:tom@jerakeen.org ]].
# Some urls are [[ ftp://not.http.urls/and/have/paths ]].
# '
#     expected: 'this is a long string with [[ http://www.news.com/ ]] urls in it in
# [[ http://various.com/ ]] different forms. [[ mailto:tom@jerakeen.org ]].
# Some urls are [[ ftp://not.http.urls/and/have/paths ]].
# '
#   Failed test 'got news.com uri'
#   at t/find.t line 49.
#          got: 'http://weird.com/url/%c3%a9withunicode'
#     expected: 'http://weird.com/url/%C3%A9withunicode'
# Looks like you failed 4 tests of 16.
t/find.t .. 
Dubious, test returned 4 (wstat 1024, 0x400)
Failed

This is caused by upgrading perl-URI-Find from version 20140702 to 20140709. URI::Find stopped translating URIs to canonical form (see URI-Find changelog).


Note You need to log in before you can comment on or make changes to this bug.