Bug 1124424 - Difference in Jackson JAR files in RPM and ZIP distribution
Summary: Difference in Jackson JAR files in RPM and ZIP distribution
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: RPMs
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Fernando Nasser
QA Contact: Katerina Odabasi
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 13:04 UTC by Zbyněk Roubalík
Modified: 2015-02-20 11:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 13:56:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Zbyněk Roubalík 2014-07-29 13:04:29 UTC
Description of problem:
Jackson JARs for RPM were compiled on JDK6, for ZIP distribution compiled on JDK7. Thus there are some differencies in these JARs, in classes metadata, META-INF/MANIFEST.MF, etc.

But both versions were compiled for JDK5, so it is not a functional issue. 

Version-Release number of selected component (if applicable):
EAP 6.3.0.ER10, RHEL5 i386

Different jars:
jackson-xc 
jackson-mapper-asl 
jackson-core-asl 
jackson-jaxrs

Comment 1 Fernando Nasser 2014-07-29 13:56:36 UTC
This is not a regression.  It has been like that since EAP 6.0.1 and it is a well known fact that RPMs have to be recompiled for each OS (differently from MEAD wrappers).  BTW, this affects ASM as well.  These are the last two non-MEAD builds left (they proven to be hard to get in MEAD on the current versions at least, which are not built with Maven upstream).

The the differences are expected.


Note You need to log in before you can comment on or make changes to this bug.