Bug 1124426 - Wrong sorting of DC's storage type
Summary: Wrong sorting of DC's storage type
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.6.0
Assignee: Eli Mesika
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 13:07 UTC by Allon Mureinik
Modified: 2016-02-10 19:30 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-02 11:12:39 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Allon Mureinik 2014-07-29 13:07:13 UTC
Description of problem:
When sorting DCs according to their storage types the result are sorted incorrectly.

Version-Release number of selected component (if applicable):
[ovirt@localhost ~]$ rpm -qa | grep ovirt-engine
ovirt-engine-lib-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-setup-plugin-websocket-proxy-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-jboss-as-7.1.1-1.el6.x86_64
ovirt-engine-tools-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-websocket-proxy-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-extensions-api-impl-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-restapi-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-backend-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-setup-base-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-userportal-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-setup-plugin-ovirt-engine-common-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-cli-3.5.0.2-1.el6.noarch
ovirt-engine-webadmin-portal-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-sdk-python-3.5.0.3-1.el6.noarch
ovirt-engine-dbscripts-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch
ovirt-engine-setup-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create a datacenter named dcShared with a "shared" storage type
2. Create a datacenter named dcLocal with a "local" storage type
3. In the "Data Center" main tab Click the "Storage Type" header in order to sort DCs in ASCENDING order of the storage type.

Actual results:
"Shared" DCs are displayed before "Local" DCs.

Expected results:
The sorting should be lexicographic: "Local" DCs should be displayed before "Shared" DCs.

Additional info:
IIUC, the sort is done by the boolean value in the database (storage_pool.is_local) instead of by the I18Ned display value.
If this is true, this is a gap in the sorting infra structure, so flagging the bug as "ux". If this is incorrect, please move to the proper group (storage? infra?) and advise on what should be done.

Comment 1 Einav Cohen 2014-09-11 17:09:05 UTC
since the bug is in the search-based sorting infrastructure, flagging as "infra" (i.e. sorting via the rest-api will produce the same result). 

I am not quite sure how the server (search-based) sorting can be aware of values displayed only in the GUI; moreover, if tomorrow we will localize these values, the sorting-order may need to be different for different locales; so not quire sure what is the correct behavior and how this should be addressed (client sorting will produce wrong results since the client always holds only one page of the search results).

Comment 2 Oved Ourfali 2014-09-28 06:37:33 UTC
The localization issue is a hard one in this case.
It will anyway require a deep infrastructural change, so moving it to 3.6.0, to consider it then.

Comment 3 Oved Ourfali 2015-06-02 11:12:39 UTC
Given comment #1 and comment #2, I don't think we'll prioritize that.
It requires more that just to "sort".
Closing as WONTFIX. If it still bothers you, please re-open for future consideration.


Note You need to log in before you can comment on or make changes to this bug.