Bug 1124439 - "pulseaudio-libs-5.0-8.fc21.x86_64 requires libjson-c.so.3"
Summary: "pulseaudio-libs-5.0-8.fc21.x86_64 requires libjson-c.so.3"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: json-c
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Meng
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1124909 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 13:38 UTC by Peter H. Jones
Modified: 2014-08-02 03:30 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-02 03:30:13 UTC


Attachments (Terms of Use)

Description Peter H. Jones 2014-07-29 13:38:10 UTC
Description of problem:
Unresolved dependency

Version-Release number of selected component (if applicable):
pulseaudio-libs-5.0-8.fc21.x86_64

How reproducible:
Live build

Steps to Reproduce:
1. See https://kojipkgs.fedoraproject.org//work/tasks/6892/7206892/root.log (FC22) and https://kojipkgs.fedoraproject.org//work/tasks/6648/7206648/root.log (FC21), search for "json"

Actual results:
Failed build

Expected results:
Normal build

Additional info:
First noticed on my a custon FC21 build I am working on.

Comment 1 Peter H. Jones 2014-07-29 13:45:57 UTC
Found pulseaudio-5.0-9.fc21.x86_64.rpm et al at
at http://koji.fedoraproject.org/koji/buildinfo?buildID=548525 . Will try those.

Comment 2 Peter H. Jones 2014-07-29 14:08:16 UTC
Giving up for today. All today's builds I see at http://koji.fedoraproject.org/koji/tasks?method=createLiveCD&state=all&view=tree&order=-id are broken, probably because of the same bug. I've checked just a few.

Comment 3 Rex Dieter 2014-07-30 01:19:56 UTC
It would appear json-c pushed a broken update, reassigning.

Comment 4 Christopher Meng 2014-07-30 02:04:12 UTC
Per devel suggestions, I've canceled the soname bump as it shouldn't be done by downstream(for future it's hard to maintain).

https://lists.fedoraproject.org/pipermail/devel/2014-July/201296.html

So please rebuild again... Sorry for the noise...

Comment 5 Rex Dieter 2014-08-01 01:22:54 UTC
*** Bug 1124909 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.