Bug 1124470 - error when registering system: RemoteServerException: Server error attempting a GET to /katello/api/owners/Default_Organization/environments?name=Library returned status 404
Summary: error when registering system: RemoteServerException: Server error attempting...
Keywords:
Status: CLOSED DUPLICATE of bug 1123514
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Registration
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 14:43 UTC by Jan Hutař
Modified: 2014-07-29 14:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-29 14:56:21 UTC


Attachments (Terms of Use)

Description Jan Hutař 2014-07-29 14:43:12 UTC
Description of problem:
There is an error when you register system via subscription-manager.


Version-Release number of selected component (if applicable):
Server side:
  Satellite-6.0.4-RHEL-6-20140723.0
Client side:
  subscription-manager-1.11.3-10.el5
  python-rhsm-1.11.3-5.el5


How reproducible:
always


Steps to Reproduce:
1. Have a Sat6 system with:
   * "RHEL" and "Sat6Tools" custom products with synced content
   * published content view containing these two repositories
   * promote that CV to "Library"
2. Discover how to register content host
   Hosts -> Content Hosts -> Register Content Host
   it says I should use:
   # subscription-manager register --org="Default_Organization" \
     --environment="Library"
3. On client (after you install katello-ca-consumer-latest.noarch.rpm) run
   the command


Actual results:
=== on client side: ===

# subscription-manager register --org="Default_Organization" --environment="Library"
WARNING

This system has already been registered with Red Hat using RHN Classic.

Your system is being registered again using Red Hat Subscription Management. Red Hat recommends that customers only register once.

To learn how to unregister from either service please consult this Knowledge Base Article: https://access.redhat.com/kb/docs/DOC-45563
Username: admin
Password: 
Remote server error. Please check the connection details, or see /var/log/rhsm/rhsm.log for more information.
# tail -n 30 /var/log/rhsm/rhsm.log
2014-07-29 14:21:08,055 [DEBUG] subscription-manager @hwprobe.py:778 - virt-what stderr: 
2014-07-29 14:21:08,055 [INFO] subscription-manager @hwprobe.py:766 - virt.is_guest: True
2014-07-29 14:21:08,055 [INFO] subscription-manager @hwprobe.py:767 - virt.host_type: kvm
2014-07-29 14:21:08,063 [INFO] subscription-manager @hwprobe.py:822 - virt.uuid: 08e54264-e84f-2661-fe21-7cba3e6330ea
2014-07-29 14:21:08,065 [DEBUG] subscription-manager @connection.py:419 - Loaded CA certificates from /etc/rhsm/ca/: redhat-uep.pem, candlepin-local.pem, candlepin-stage.pem
2014-07-29 14:21:08,065 [DEBUG] subscription-manager @connection.py:451 - Making request: GET /katello/api/
2014-07-29 14:21:10,200 [DEBUG] subscription-manager @connection.py:474 - Response: status=200
2014-07-29 14:21:10,201 [DEBUG] subscription-manager @connection.py:691 - Server supports the following resources:
2014-07-29 14:21:10,201 [DEBUG] subscription-manager @connection.py:692 - {'available_releases': '/katello/api/available_releases', 'tasks': '/katello/api/tasks/', 'distributors': '/katello/api/distributors/', 'content_overrides': '/katello/api/content_overrides', 'environments': '/katello/api/environments/', 'content_views': '/katello/api/content_views/', 'content_view_filters': '/katello/api/content_view_filters/', 'puppet_modules': '/katello/api/puppet_modules/', 'host_collections': '/katello/api/host_collections/', 'guestids': '/katello/api/guestids', 'systems': '/katello/api/systems/', 'gpg_keys': '/katello/api/gpg_keys/', 'status': '/katello/api/status/', 'capsules': '/katello/api/capsules/', 'users': '/katello/api/users/', 'sync_plans': '/katello/api/sync_plans/', 'subscriptions': '/katello/api/subscriptions/', 'content_view_versions': '/katello/api/content_view_versions/', 'packages': '/katello/api/packages/', 'organizations': '/katello/api/organizations/', 'package_groups': '/katello/api/package_groups/', 'repository_sets': '/katello/api/repository_sets/', 'repositories': '/katello/api/repositories/', 'products': '/katello/api/products/', 'activation_keys': '/katello/api/activation_keys/', 'errata': '/katello/api/errata/'}
2014-07-29 14:21:10,203 [DEBUG] subscription-manager @connection.py:419 - Loaded CA certificates from /etc/rhsm/ca/: redhat-uep.pem, candlepin-local.pem, candlepin-stage.pem
2014-07-29 14:21:10,203 [DEBUG] subscription-manager @connection.py:451 - Making request: GET /katello/api/owners/Default_Organization/environments?name=Library
2014-07-29 14:21:12,324 [DEBUG] subscription-manager @connection.py:474 - Response: status=404
2014-07-29 14:21:12,324 [ERROR] subscription-manager @connection.py:503 - Response: 404
2014-07-29 14:21:12,325 [ERROR] subscription-manager @connection.py:504 - JSON parsing error: No JSON object could be decoded
2014-07-29 14:21:12,325 [ERROR] subscription-manager @managercli.py:156 - Error during registration: Server error attempting a GET to /katello/api/owners/Default_Organization/environments?name=Library returned status 404
2014-07-29 14:21:12,325 [ERROR] subscription-manager @managercli.py:157 - Server error attempting a GET to /katello/api/owners/Default_Organization/environments?name=Library returned status 404
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1030, in _do_command
    self.options.environment)
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1121, in _get_environment_id
    env = cp.getEnvironment(owner_key=owner_key, name=environment_name)
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 1107, in getEnvironment
    results = self.conn.request_get(url)
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 555, in request_get
    return self._request("GET", method)
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 483, in _request
    self.validateResponse(result, request_type, handler)
  File "/usr/lib64/python2.4/site-packages/rhsm/connection.py", line 531, in validateResponse
    handler=handler)
RemoteServerException: Server error attempting a GET to /katello/api/owners/Default_Organization/environments?name=Library returned status 404

=== on server side ===

==> /var/log/foreman/production.log <==
Processing by Katello::Api::V2::RootController#resource_list as JSON
  Parameters: {"api_version"=>"v2", "root"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/root/resource_list.json.rabl within katello/api/v2/layouts/collection (6.1ms)
Completed 200 OK in 31ms (Views: 7.5ms | ActiveRecord: 0.0ms)
Processing by Katello::Api::V2::PingController#server_status as JSON
  Parameters: {"api_version"=>"v2", "ping"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/ping/server_status.json.rabl within katello/api/v2/layouts/resource (238.6ms)
Completed 200 OK in 242ms (Views: 240.0ms | ActiveRecord: 0.0ms)
Processing by Katello::Api::V2::RootController#resource_list as JSON
  Parameters: {"api_version"=>"v2", "root"=>{}}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/katello-1.5.0/app/views/katello/api/v2/root/resource_list.json.rabl within katello/api/v2/layouts/collection (6.4ms)
Completed 200 OK in 33ms (Views: 7.7ms | ActiveRecord: 0.0ms)

ActionController::RoutingError (No route matches [GET] "/katello/api/owners/Default_Organization/environments"):
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/rack/thread_handler_extension.rb:77:in `process_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:140:in `accept_and_process_next_request'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
  /usr/lib/ruby/gems/1.8/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'


Expected results:
Should work.

Comment 2 Jan Hutař 2014-07-29 14:56:21 UTC

*** This bug has been marked as a duplicate of bug 1123514 ***


Note You need to log in before you can comment on or make changes to this bug.