Bug 112451 - [RHEL3_U4]LTC5670-RHEL3-Update1: oprof_start can't be started because of miss-placed unit mask description file
[RHEL3_U4]LTC5670-RHEL3-Update1: oprof_start can't be started because of miss...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: oprofile (Show other bugs)
3.0
powerpc Linux
medium Severity low
: ---
: ---
Assigned To: William Cohen
:
Depends On:
Blocks: 132991 146413
  Show dependency treegraph
 
Reported: 2003-12-19 16:50 EST by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 16:26:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-12-19 16:50:06 EST
The following has be reported by IBM LTC:  
RHEL3-Update1: oprof_start can't be started because of miss-placed
unit mask description file
Hardware Environment:
   	pSeries p630 7028-6C4, 4GB RAM, 2-way CPU
   
Software Environment:
         RHEL3-Update1

Steps to Reproduce:
1. using opcontrol to configure and start oprofile
[root@plinuxt5 quota-tools]# opcontrol
--vmlinux=/boot/vmlinux-2.4.21-6.EL 
[root@plinuxt5 quota-tools]# opcontrol --start
Using log file /var/lib/oprofile/oprofiled.log
Daemon started.
Profiler running.

2. using oprof_start to setup profiler in graphic mode
[root@plinuxt5 quota-tools]# oprof_start 
Xlib:  extension "GLX" missing on display ":1.0".
Xlib:  extension "GLX" missing on display ":1.0".
oprofile: could not open unit mask description 
file /usr/share/oprofile/timer/unit_masks

Actual Results:
   oprof_start can't be started 

Expected Results:
   oprof_start could be started

Additional Information:
   there is a directory named /usr/share/oprofile/rtc, under which
there are 
two files named unit-masks and events. After copying these two files 
to /usr/share/oprofile/timer/. oprof_start could be startedGlen/Greg -
this is shipped with RHEL3 and I don't think we have permission to
contribute code to oprofiler, so please submit this to Red Hat.  Thanks.
Comment 1 IBM Bug Proxy 2004-02-06 09:47:16 EST
------- Additional Comment #3 From Wu Zhou  2004-01-11 23:46 -------

this defect still exist in RHEL update1 20040108 build.


------- Additional Comment #4 From Khoa D. Huynh 2004-02-06 09:44 -------

I've put this on RHEL3 QU3 list as a Sev 3.

Comment 2 William Cohen 2004-02-07 12:15:50 EST
One can start oprofile with:

opcontrol --setup --vmlinux=/boot/vmlinux-`uname -r`
opcontrol --start

One can shutdown oprofile with

opcontrol --shutdown

The defect does still exist in oprofile in RHEL3 U1. Copying over the
unitmasks files does not look like the correct fix. Problem appears to
be resolved in the current versions of OProfile. Will examining
backporting those corrections.
Comment 3 IBM Bug Proxy 2004-02-23 01:49:47 EST
----- Additional Comments From khoa@us.ibm.com  2004-02-23 01:48 -------
Any update from Red Hat on this ? 
Comment 4 IBM Bug Proxy 2004-04-07 06:05:51 EDT
----- Additional Comments From zhouwu@cn.ibm.com  2004-04-07 06:05 -------
Hello all,

  With the 03/30 released RHEL U2 Beta, oprof_start is not shipped in oprofile 
package. Do we not need oprof_start any more? Following is the file list of 
oprofile-0.5.4 package:

[root@plinux9 root]# rpm -qilf `which opcontrol`
Name        : oprofile                     Relocations: (not relocatable)
Version     : 0.5.4                             Vendor: Red Hat, Inc.
Release     : 16                            Build Date: Thu 26 Feb 2004 
01:52:28 AM CST
Install Date: Wed 07 Apr 2004 05:07:37 AM CST      Build Host: 
cure81.devel.redhat.com
Group       : Development/System            Source RPM: oprofile-0.5.4-
16.src.rpm
Size        : 3814811                          License: GPL
Signature   : DSA/SHA1, Thu 11 Mar 2004 03:34:31 AM CST, Key ID fd372689897da07a
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://oprofile.sf.net
Summary     : A system-wide profiler.
Description :
OProfile is a profiling system for Linux.  Profiling runs transparently in
the background, and profile data can be collected at any time. OProfile
makes use of hardware performance counters provided by many processors, and
can use the RTC for profiling on other processor types.
/usr/bin/op_help
/usr/bin/op_import
/usr/bin/op_merge
/usr/bin/op_time
/usr/bin/op_to_source
/usr/bin/op_visualise
/usr/bin/opcontrol
/usr/bin/oprofiled
/usr/bin/oprofpp
/usr/share/doc/oprofile-0.5.4
/usr/share/doc/oprofile-0.5.4/oprofile.html
/usr/share/man/man1/op_help.1.gz
/usr/share/man/man1/op_merge.1.gz
/usr/share/man/man1/op_time.1.gz
/usr/share/man/man1/op_to_source.1.gz
/usr/share/man/man1/op_visualise.1.gz
/usr/share/man/man1/opcontrol.1.gz
/usr/share/man/man1/oprofile.1.gz
/usr/share/man/man1/oprofiled.1.gz
/usr/share/man/man1/oprofpp.1.gz
/usr/share/oprofile/alpha
/usr/share/oprofile/alpha/ev4
/usr/share/oprofile/alpha/ev4/events
/usr/share/oprofile/alpha/ev4/unit_masks
/usr/share/oprofile/alpha/ev5
/usr/share/oprofile/alpha/ev5/events
/usr/share/oprofile/alpha/ev5/unit_masks
/usr/share/oprofile/alpha/ev6
/usr/share/oprofile/alpha/ev6/events
/usr/share/oprofile/alpha/ev6/unit_masks
/usr/share/oprofile/alpha/ev67
/usr/share/oprofile/alpha/ev67/events
/usr/share/oprofile/alpha/ev67/unit_masks
/usr/share/oprofile/alpha/pca56
/usr/share/oprofile/alpha/pca56/events
/usr/share/oprofile/alpha/pca56/unit_masks
/usr/share/oprofile/i386
/usr/share/oprofile/i386/athlon
/usr/share/oprofile/i386/athlon/events
/usr/share/oprofile/i386/athlon/unit_masks
/usr/share/oprofile/i386/p4
/usr/share/oprofile/i386/p4-ht
/usr/share/oprofile/i386/p4-ht/events
/usr/share/oprofile/i386/p4-ht/unit_masks
/usr/share/oprofile/i386/p4/events
/usr/share/oprofile/i386/p4/unit_masks
/usr/share/oprofile/i386/pii
/usr/share/oprofile/i386/pii/events
/usr/share/oprofile/i386/pii/unit_masks
/usr/share/oprofile/i386/piii
/usr/share/oprofile/i386/piii/events
/usr/share/oprofile/i386/piii/unit_masks
/usr/share/oprofile/i386/ppro
/usr/share/oprofile/i386/ppro/events
/usr/share/oprofile/i386/ppro/unit_masks
/usr/share/oprofile/ia64
/usr/share/oprofile/ia64/ia64
/usr/share/oprofile/ia64/ia64/events
/usr/share/oprofile/ia64/ia64/unit_masks
/usr/share/oprofile/ia64/itanium
/usr/share/oprofile/ia64/itanium/events
/usr/share/oprofile/ia64/itanium/unit_masks
/usr/share/oprofile/ia64/itanium2
/usr/share/oprofile/ia64/itanium2/events
/usr/share/oprofile/ia64/itanium2/unit_masks
/usr/share/oprofile/rtc
/usr/share/oprofile/rtc/events
/usr/share/oprofile/rtc/unit_masks
/usr/share/oprofile/stl.pat
/usr/share/oprofile/x86-64
/usr/share/oprofile/x86-64/hammer
/usr/share/oprofile/x86-64/hammer/events
/usr/share/oprofile/x86-64/hammer/unit_masks
/usr/share/oprofile/x86-64/ia32e
/usr/share/oprofile/x86-64/ia32e-ht
/usr/share/oprofile/x86-64/ia32e-ht/events
/usr/share/oprofile/x86-64/ia32e-ht/unit_masks
/usr/share/oprofile/x86-64/ia32e/events
/usr/share/oprofile/x86-64/ia32e/unit_masks
[root@plinux9 root]# 
Comment 5 William Cohen 2004-04-07 12:40:32 EDT
There is no intent to remove oprof_start. This appears to be a problem
with the build system. If qt unavailable or not found, the gui
programs (oprof_start) are not built. Investigating this problem now.

Comment 6 William Cohen 2004-04-16 15:03:49 EDT
The oprof_start wasn't compiled in some build, because of a path
problem for QTDIR. Qt wasn't found and as a result the graphical stuff
such as oprof_start was not compiled. This is corrected in 0.5.4-20
and newer builds of oprofile rpm.

Still doesn't fix the problem with oprof_start not working with timer
based machines.
Comment 7 IBM Bug Proxy 2004-07-09 01:55:45 EDT
----- Additional Comments From khoa@us.ibm.com  2004-07-09 01:51 -------
Any update on this bug ? 
Comment 12 IBM Bug Proxy 2004-11-08 22:28:21 EST
----- Additional Comments From zhouwu@cn.ibm.com  2004-11-08 21:24 EDT -------
oprof_start can't yet be started in rhel3-U3, but it could be started in rhel4-
beta2. What is the plan for Redhat on this problem? Thanks. 
Comment 13 William Cohen 2004-12-03 10:11:55 EST
OProfile in RHEL3 is based on 0.5.4 and RHEL4 beta is based on 0.8.
There were a number of changes made in the gui. Due to the changes in
the user interface Red Hat can't just replace the 0.5.4 version with
the newer version.
Comment 14 IBM Bug Proxy 2005-03-18 08:35:47 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |wangzyu@cn.ibm.com,
                   |                            |bujunhui@cn.ibm.com,
                   |                            |fangwenq@cn.ibm.com,
                   |                            |zengjinz@cn.ibm.com,
                   |                            |zhuyaof@cn.ibm.com




------- Additional Comments From wangzyu@cn.ibm.com  2005-03-18 08:30 EST -------
  The defect do NOT fix on RHEL3 U4(official kernel: 2.4.21-27.EL).
[root@trivialp1 root]# rpm -qlif `which oprof_start `
Name        : oprofile                     Relocations: (not relocatable)
Version     : 0.5.4                             Vendor: Red Hat, Inc.
Release     : 22                            Build Date: Mon 19 Apr 2004 
11:25:25 AM EDT
Install Date: Thu 17 Mar 2005 09:42:37 AM EST      Build Host: 
cure81.build.redhat.com
Group       : Development/System            Source RPM: oprofile-0.5.4-
22.src.rpm
Size        : 4002169                          License: GPL
Signature   : DSA/SHA1, Thu 22 Apr 2004 06:01:20 PM EDT, Key ID 219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://oprofile.sf.net
Summary     : A system-wide profiler. 
Comment 15 IBM Bug Proxy 2005-04-22 05:24:23 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |tianq@cn.ibm.com,
                   |                            |shenlinf@cn.ibm.com




------- Additional Comments From wangzyu@cn.ibm.com  2005-04-22 05:17 EDT -------
  The defect do NOT fix on RHEL3 U5(official kernel: 2.4.21-31.EL). We notice 
that the version of oprofile is same with RHEL3 U4: 
===================================
[root@plinuxt8 root]# rpm -qlif `which oprof_start `
Name        : oprofile                     Relocations: (not relocatable)
Version     : 0.5.4                             Vendor: Red Hat, Inc.
Release     : 22                            Build Date: Mon 19 Apr 2004 
11:25:25 AM EDT
Install Date: Wed 13 Apr 2005 03:49:06 AM EDT      Build Host: 
cure81.build.redhat.com
Group       : Development/System            Source RPM: oprofile-0.5.4-
22.src.rpm
Size        : 4002169                          License: GPL
Signature   : DSA/SHA1, Thu 22 Apr 2004 06:01:20 PM EDT, Key ID 
219180cddb42a60e
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla> 
Comment 16 IBM Bug Proxy 2005-06-01 17:50:40 EDT
---- Additional Comments From marksmit@us.ibm.com  2005-06-01 17:38 EDT -------
This append is being added to 63 IBM/LTC bugzilla's. As of 6/1/2005 the bug 
submitter in this bug is no longer working in this area of IBM, testing of 
Linux distros.  Unfortunately, the bug submitter is not an edit-able field 
with LTCBugzilla.  The bug submitter will no longer be available for 
recreation attempts or patch testing.  Those requests will need to be made to 
the bug owner.
If the bug owner needs assistance with access to the machine, please contact 
via email/Sametime: dino@us.ibm.com .  I will be Dino's backup if he is un-
available:via email, SameTime or phone.

If the bug submitter disagrees with the above statements, I apologize if I 
made an error in the bug sort.  Please correct the appropriate bug by adding 
your own public (not internal) comment. 
Comment 17 IBM Bug Proxy 2005-08-08 15:44:40 EDT
---- Additional Comments From gsmith@us.ibm.com  2005-08-08 15:37 EDT -------
From Maynard Johnson, Toolchain: "Technically, PPC64 was not supported on the 
version of Oprofile included with RHEL 3 (Oprofile 0.5.4).  Timer mode 
profiling may have worked, but most other functions would not.  Full PPC64 
support was included in  RHEL 4 (via OProfile 0.8.1) and the particular 
failing function described in bug 5670 now works as it should."

If being fixed in RHEL4 is good enough (especially at this late date), this 
should suffice to close this defect. 
Comment 18 IBM Bug Proxy 2005-08-15 20:41:23 EDT
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REJECTED                    |CLOSED




------- Additional Comments From zhouwu@cn.ibm.com  2005-08-15 20:21 EDT -------
OK. Mark as closed. 
Comment 19 Elena Zannoni 2005-09-28 16:26:38 EDT
Closing the RH side as well, then.

Note You need to log in before you can comment on or make changes to this bug.