Bug 1124514 - upgrade: service by service upgrade - should dashboard be before neutron
Summary: upgrade: service by service upgrade - should dashboard be before neutron
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Upgrade
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 5.0 (RHEL 6)
Assignee: Don Domingo
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 16:40 UTC by Dafna Ron
Modified: 2015-01-19 03:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-19 03:30:19 UTC


Attachments (Terms of Use)

Description Dafna Ron 2014-07-29 16:40:57 UTC
Description of problem:

since neutron has extra configuration on the computes much like nova, I am not sure it should be upgraded before the dashboard upgrade. 

Version-Release number of selected component (if applicable):


https://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/5/html/Upgrade_Guide/sect-Method_-_Upgrade_Service-by-Service_with_Live_Compute_Upgrade.html#Configure_OpenStack_Networking_as_Part_of_Upgrade

How reproducible:


Steps to Reproduce:
1. upgrade service by service with live compute upgrade
2.
3.

Actual results:

neutron is upgraded before the dashboard 

Expected results:

since there is configuration we have to do manually on all the computes for neutron as well, I think perhaps neutron should be updated after the dashboard 
and have it's own section (like nova) with all the needed configuration for both the controller/networker/computes. 

Additional info:

Comment 1 Andrew Dahms 2014-07-30 00:43:17 UTC
This bug is being assigned to Martin Lopes, who is the designated docs specialist for Neutron.


Note You need to log in before you can comment on or make changes to this bug.