Bug 1124522 - Cannot install on Hyper-V Generation 2 VM
Summary: Cannot install on Hyper-V Generation 2 VM
Keywords:
Status: CLOSED DUPLICATE of bug 1127364
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: grub
Version: 6.6
Hardware: x86_64
OS: Windows
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 17:21 UTC by Chris
Modified: 2014-09-10 09:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-14 13:34:58 UTC


Attachments (Terms of Use)
Console view when Secure boot is disabled for the VM (19.13 KB, image/png)
2014-07-29 17:21 UTC, Chris
no flags Details

Description Chris 2014-07-29 17:21:10 UTC
Description of problem:
We discovered that the installation of RHEL 6.6 is not possible on a Hyper-V Generation 2 VM.

Version-Release number of selected component (if applicable):
RHEL-6.6-20140718.0-Server-x86_64-dvd1
Windows Server 2012R2 with Hyper-V

How reproducible:
100%

Steps to Reproduce:
1. create in Hyper-V a Gen2 VM
2. from the VM settings window, go to the Firmware menu and un-check 'Enable Secure boot'.
3. Start the VM with the RHEL 6.6 ISO attached.
4. The screen will remain blank.

Actual results:
Screen remains blank, the VM will not boot from the ISO.
If step 2 is skipped (VM Secure boot enabled by default), the VM will fail to find the DVD boot device.

Expected results:
Installation process should start.

Additional info:

Comment 1 Chris 2014-07-29 17:21:53 UTC
Created attachment 922238 [details]
Console view when Secure boot is disabled for the VM

Comment 3 Jan Grulich 2014-08-12 14:20:19 UTC
Can you try it with the latest snapshot? There were some issues which are already fixed.

Comment 4 Jan Grulich 2014-08-14 13:34:58 UTC

*** This bug has been marked as a duplicate of bug 1127364 ***

Comment 5 Chris 2014-08-20 17:27:33 UTC
Hi Jan,
Can you please grant us access to the mentioned duplicate bug 1127364 ? Please add all the 3 recipients from this bug.

Just for the record we've tried to install Beta1 on a Gen2 VM and it's still not working, so we need to follow-up this through.
Thank you!

Comment 6 Dexuan Cui 2014-09-03 05:48:41 UTC
I can't access bug 1127364 either... :-(
Please grant me the permission too.

Comment 7 Dexuan Cui 2014-09-04 07:37:45 UTC
Great! I can access bug 1127364 now.

Comment 8 Dexuan Cui 2014-09-04 14:43:44 UTC
(In reply to Jan Grulich from comment #4)
> 
> *** This bug has been marked as a duplicate of bug 1127364 ***

Hi Jan or Chris,
Is is possible for you to help to verify the bug with the "Latest nightly build of RHEL 6.6 Server ISO"(see bug 1127364 for the latest build) ?

I'm not sure if the 2 bugs are the exactly same since this bug happens to a hyperv guest, and the other bug happens on some native platform?

Should I reopen the bug?

Comment 9 Dexuan Cui 2014-09-05 06:15:59 UTC
Looks I don't have the permission to reopen the bug. :-(
Can Jan Grulich please reopen the bug?

I think we need to re-test this bug using the latest RHEL6.6 beta build with "grub-0.97-98 or newer".
We can't assume this bug is exactly the same as bug 1127364 because the occurring platforms of the 2 bugs are different.

Comment 10 Kylie 2014-09-10 06:20:52 UTC
Who could help verify this bug with latest RHEL 6.6 beta version?

Comment 11 Yaju Cao 2014-09-10 07:04:56 UTC
Hi Kylie and Dexuan,

We have tried to install a Generation 2 VM with latest RHEL6.6 build on Hyper-V 2012 R2 host. There are still some issues filed as below, but it seems not the same as this bug.

1. Bug 1132770 - [Hyper-V][ESX][RHEL6.6]UEFI install using ISO can not continue on "Disk Found" page. ISO media could loaded, but not a blank screen, from which I believe this bug should be resolved. 

2. Bug 1135951 - [Hyper-V][RHEL6.6] Guest startup panic after complete install Gen2 VM. We could manage to install a Gen2 VM by PXE or serial connect, but system would kernel panic after boot up.

So I suggest to keep this bug as closed and track Gen2 issues with the new bugs.

Comment 12 Dexuan Cui 2014-09-10 09:18:37 UTC
I agree with Yaju on Comment 11.
Thanks, Yaju!


Note You need to log in before you can comment on or make changes to this bug.