Bug 11246 - zsh man pages are incorrectly formatted
zsh man pages are incorrectly formatted
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: zsh (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-05 11:58 EDT by dh_redhat
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-15 15:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dh_redhat 2000-05-05 11:58:11 EDT
> The man pages for zsh (zsh-3.0.7-4) are not generated right. In
particular
> /usr/man/man1/zshall.1.gz should have links inside to other man pages
like
> zshbuiltins, ... zshzle. zshall is a master man page for all the
sections.
> Because the files are gzipped, catman is looking for zshmisc.1 instead of
> zshmisc.1.gz, so it won't find it, so the man page zshall will be
incomplete
> which is really inconvenient. It's been like this for the past few
release
> of RedHat, I am surprised nobody noticed.
>
> Workaround:
>
> su root
> cd /usr/man/man1
> gunzip zsh*
> rm /var/catman/cat1/zshall.1.gz
> man zshall
>
> Thank you for a future fix.
Comment 1 Trond Eivind Glomsrxd 2000-05-05 14:32:59 EDT
This problem doesn't seem to occur with the Rawhide version (3.0.7-5). Can you
check that one, and reopen if the bug still occurs?
Comment 2 dh_redhat 2000-05-14 01:42:59 EDT
There's no zsh 3.0.7-5 in RawHide. I am looking at

ftp://rawhide.redhat.com/rawhide/i386/RedHat/RPMS/

and all I see is  zsh-3.0.7-4.i386.rpm . . . . . . Mar  8 20:43    470k

I cannot try the version you mentioned so I am reopening the bug.
Comment 3 Trond Eivind Glomsrxd 2000-05-15 15:18:59 EDT
That's because a new RawHide ahsn't been released since the fix.
Comment 4 Thomas Bjvrklund 2000-11-24 05:24:29 EST
In zsh-3.0.8-3 this bug is not fixed;
root@diglab3:/var/cache/man/cat1>rm zshall.1.gz 
rm: remove `zshall.1.gz'? y
root@diglab3:/var/cache/man/cat1>man zshall
Formatting page, please wait...
<standard input>:23: realpath on `man1/zshmisc.1' failed: No such file or
directory
<standard input>:24: realpath on `man1/zshexpn.1' failed: No such file or
directory
<standard input>:25: realpath on `man1/zshbuiltins.1' failed: No such file or
directory
<standard input>:26: realpath on `man1/zshcompctl.1' failed: No such file or
directory
<standard input>:27: realpath on `man1/zshparam.1' failed: No such file or
directory
<standard input>:28: realpath on `man1/zshzle.1' failed: No such file or
directory
<standard input>:29: realpath on `man1/zshoptions.1' failed: No such file or
directory

Note You need to log in before you can comment on or make changes to this bug.