Bug 1124600 - when transaction is aborted due to file conflict, yum thinks it's an unfinished transaction
Summary: when transaction is aborted due to file conflict, yum thinks it's an unfinish...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-29 21:38 UTC by Andre Robatino
Modified: 2018-07-18 21:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-18 21:31:26 UTC


Attachments (Terms of Use)

Description Andre Robatino 2014-07-29 21:38:31 UTC
Description of problem:
See Summary.

[root@localhost ~]# yum --skip-broken distro-sync filesystem
Loaded plugins: langpacks
Resolving Dependencies
--> Running transaction check
---> Package filesystem.x86_64 0:3.2-27.fc22 will be updated
---> Package filesystem.x86_64 0:3.2-28.fc22 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch           Version                Repository       Size
================================================================================
Updating:
 filesystem         x86_64         3.2-28.fc22            rawhide         1.1 M

Transaction Summary
================================================================================
Upgrade  1 Package

Total size: 1.1 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction (shutdown inhibited)
Transaction couldn't start:
file /media from install of filesystem-3.2-28.fc22.x86_64 conflicts with file from package filesystem-3.2-27.fc22.x86_64


[('file /media from install of filesystem-3.2-28.fc22.x86_64 conflicts with file from package filesystem-3.2-27.fc22.x86_64', (7, '/media', 3258L))]
[root@localhost ~]# yum --skip-broken distro-sync filesystem
Loaded plugins: langpacks
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction, or "yum-complete-transaction --cleanup-only" and "yum history redo last", first to finish them. If those don't work you'll have to try removing/installing packages by hand (maybe package-cleanup can help).
--> Running transaction check
---> Package filesystem.x86_64 0:3.2-27.fc22 will be updated
---> Package filesystem.x86_64 0:3.2-28.fc22 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package            Arch           Version                Repository       Size
================================================================================
Updating:
 filesystem         x86_64         3.2-28.fc22            rawhide         1.1 M

Transaction Summary
================================================================================
Upgrade  1 Package

Total size: 1.1 M
Is this ok [y/d/N]:

Version-Release number of selected component (if applicable):
yum-3.4.3-152.fc21.noarch

How reproducible:
always

Steps to Reproduce:
1. Try to do a yum distro-sync when there's a file conflict.

Actual results:
Says "Transaction test succeeded", then says "Transaction couldn't start:" due to file conflict, then if you run the same command again, it says there are unfinished transactions. Running yum-complete-transaction can't actually complete the transaction either due to the file conflict.

Expected results:
If yum can't even start the transaction, it shouldn't consider it incomplete. In this case, there was never a transaction, so yum shouldn't be complaining.

Comment 1 Jaroslav Reznik 2015-03-03 16:10:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 2 Daniel Mach 2018-07-18 21:31:26 UTC
yum and related packages are no longer actively developed.
They are being replaced with dnf, dnf-utils, etc.

I'm closing this bug because it's most likely never going to be fixed.
If you still consider your bug report important, reopen it, please.

Comment 3 Daniel Mach 2018-07-18 21:34:13 UTC
yum and related packages are no longer actively developed.
They are being replaced with dnf, dnf-utils, etc.

I'm closing this bug because it's most likely never going to be fixed.
If you still consider your bug report important, reopen it, please.


Note You need to log in before you can comment on or make changes to this bug.