Bug 112467 - The default theme schemas could not be found when setting themes
The default theme schemas could not be found when setting themes
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: libgnome (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-20 04:02 EST by James Hsu
Modified: 2007-04-18 13:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-09 14:58:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Hsu 2003-12-20 04:02:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-TW; rv:1.2.1)
Gecko/20030225

Description of problem:
I found that some of the icon images weren't correct, so 
trying to use preference -> themes to modify it, but I got an
error message as follows:
=====================================================================
The default theme schemas could not be found on.  This means that you
probably don't have metacity installed, or that your gconf is
configured incorrectly.
=====================================================================
Please help me to solve it. Thanks a lot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Preference
2. Theme Setting
3. ...
    

Actual Results:  The default theme schemas could not be found on. 
This means that you probably don't have metacity installed, or that
your gconf is configured incorrectly.

Expected Results:  It should let me choose a theme

Additional info:
Comment 1 Kjartan Maraas 2004-05-20 09:35:46 EDT
Do you have metacity installed? How did you install your GNOME
packages? From the distro binaries or self compiled? You could try to
do 'mv .gconf .gconf.old' after logging out. This will give you a
fresh set of settings when logging back out. If that solves it maybe a
'diff -urN .gconf.old .gconf' will give some clues...
Comment 2 Andy Bailey 2004-06-02 13:06:05 EDT
Reverting from libgnome 2.6.0-3 to 2.6.0-2 seems to eliminate this
problem.  Prior to that, completely removing the user and recreating
it still let the user with a seemingly broken gconf. Users who logged
in once before the libgnome 2.6.0-3 update was installed seemed to
work alright, but if there was no .gconf dir for them, the one that
was created would be busted after that update.
Comment 3 djwdjw 2004-09-20 19:43:36 EDT
Hi,

Not a long term solution but if you do this:

chmod -R 777 /etc/gconf

- the problem is solved.

I'm sure there is a nicer way to do this (and more secure), but at
least it works!

Regards

D.
Comment 4 Ray Strode [halfline] 2005-09-09 14:58:53 EDT
Hi,

Red Hat Linux 9 is very old and now unsupported.  If you can reproduce this
problem with a recent version of RHEL or Fedora Core, feel free to reopen this bug.

Note You need to log in before you can comment on or make changes to this bug.